[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anyone have the Nvidia driver working in 2.6.11-1.14_FC3?



Jonathan Berry wrote:

On 4/13/05, Neal Wilkinson <forums lists comcast net> wrote:


Brian Gaynor wrote:



I have the latest nVidia driver (7174) working fine with
2.6.11-1.14_FC3smp, video is a GeForce FX 5200Go. Installed using the
stock nvidia-installer.





I tried it a good bit yesterday. It said that it wasn't compatible with
the kernel but was building a module. Then it said to modify the



You'll never find a pre-built kernel module. There is no way nVidia can support all kernel versions out there. Building the module should work just fine with the newest (7174) drivers. Also, you should only have to modify the xorg.conf once if you don't change it.



xorg.conf which I did. Fails on boot, saying it can't find the .ko but
it is there, although it is in a different location that with the
previous kernel. I can boot 770 with the xorg.conf I created and the
driver works fine so that isn't the issue. Did you get any errors or did
your install go fine?



This seems to indicate that you didn't install it for the new kernel. Unless you use some of the advanced options, installing for the new
kernel should have uninstalled it for the old kernel. You have a
couple of options:


1. Boot the old kernel and install the nVidia drivers with the -k
option to install for the new kernel.  You can also install just the
kernel module by using the -K option.  Use the -s option and it won't
bring up the UI or ask you any questions.
sh NVIDIA-Linux-x86-1.0-7174-pkg1.run -k 2.6.11-1.14_FC3 -K -s

2. Boot the new kernel to run-level 3 and install the nVidia drivers.

This should work.  If it does not, please send us details about what
didn't work.  Saying that the module is there but in a different
location is rather vague.  Where exactly is it?  What errors (exactly)
are you getting if any?

Jonathan



Ok...here we go.
I have version NVIDIA-Linux-x86-1.0-6629-pkg1.run installed and running in the 770 kernel. I've tried to install NVIDIA-Linux-x86-1.0-7174-pkg1.run in 2.6.10-1.741_FC3 and the following happens.


I end the session and go to a console login.
login as root
cd /home/neal (where the file is)
sh NVIDIA-Linux-x86-1.0-7174-pkg1.run
message that the same version is installed, would I like to remove it and install again. I answer yes.
then says it must download a kernel interface and says no matching one was found
then it builds the kernel module and says its done
then it uninstalls the driver and re-installs it
then says its done please go update xorg.conf etc. if needed
then when I reboot I get an error when it should load the driver which says nvidia.ko not found and it loads a generic driver.


Does this help? Thanks!

Neal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]