[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anyone have the Nvidia driver working in 2.6.11-1.14_FC3?



Marc Schwartz wrote:

Neal Wilkinson wrote:



Neal Wilkinson wrote:





Ok...here we go.
I have version NVIDIA-Linux-x86-1.0-6629-pkg1.run installed and
running
in the 770 kernel. I've tried to install
NVIDIA-Linux-x86-1.0-7174-pkg1.run in 2.6.10-1.741_FC3 and the
following
happens.

I end the session and go to a console login.
login as root
cd /home/neal (where the file is)
sh NVIDIA-Linux-x86-1.0-7174-pkg1.run
message that the same version is installed, would I like to remove it
and install again. I answer yes.
then says it must download a kernel interface and says no matching one
was found
then it builds the kernel module and says its done
then it uninstalls the driver and re-installs it
then says its done please go update xorg.conf etc. if needed
then when I reboot I get an error when it should load the driver which
says nvidia.ko not found and it loads a generic driver.

Does this help? Thanks!

Neal



SNIP




Ok...I'm sure this won't make sense but its working now. Here is what I
did.
It wasn't finding the nvidia.ko the only different in this one and the
770 kernel was the inside of /video/ there was a seperate /nvidia/
directory with the ko inside it. I made one and moved the ko file there.
Then restarted and the machine hung at the point the driver was to load.
I rebooted and I came up to a console login. I removed the driver and
then installed it there and now all is well. I really hate something
being fixed and not knowing why. Anyway, I'm glad its working. Thanks
for the help.




Neal,


A possibly dumb question, but as they say the only stupid question is
the one that goes unasked.

When you tried to install the 7174 driver as above the first time "for
the 2.6.10-1.741_FC3 kernel", had you actually booted that kernel, or
were you still running the 770 kernel?

This sounds like you were still running the 770 kernel and trying to
install the nVidia driver for the other kernel. That won't work.

You need to be running the kernel that you want to install the driver
for at the time. This is why you won't be able to use the nVidia driver
if you boot a new or different kernel relative to the last time you used
the nVidia installer.

The one inconsistency here is that usually when this situation occurs, X
won't run at all and you are left at a text console login prompt after
some initial error messages and prompts about wanting to diagnose X
problems and logs, etc.

I don't know if the Livna RPMS overcome this problem, but that may be a
possibility. Someone else here may know.

BTW, for the latest kernel, the nvidia.ko file is in:

/lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia.ko


Marc




Nope, I wasn't running 770. I did go back to 770 to check and see if it worked there which it did but then I went back to the new one. I also noticed the location was /lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia.ko/ vs lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia/nvidia.ko on 770. That is why I changed it just to see if it would help. When it booted directly to the console login I'm guessing it couldn't find anything but I don't know why it then worked after installing it again. I'm still very linux challenged so I could miss something obvious I'm guessing. Thanks again.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]