[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anyone have the Nvidia driver working in 2.6.11-1.14_FC3?



On Wed, 2005-04-13 at 20:38 -0500, Jeff Vian wrote:

>> On Wed, 2005-04-13 at 19:53 -0400, Neal Wilkinson wrote:
> > Nope, I wasn't running 770. I did go back to 770 to check and see if it 
> > worked there which it did but then I went back to the new one. I also 
> > noticed the location was 
> > /lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia.ko/  vs 
> > lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia/nvidia.ko on 
> > 770. That is why I changed it just to see if it would help. When it 
> > booted directly to the console login I'm guessing it couldn't find 
> > anything but I don't know why it then worked after installing it again. 
> > I'm still very linux challenged so I could miss something obvious I'm 
> > guessing. Thanks again.

> On Wed, 2005-04-13 at 19:15 -0500, Marc Schwartz wrote:

> > OK, your sentence:
> > 
> > "When it booted directly to the console login I'm guessing it couldn't
> > find anything but I don't know why it then worked after installing it
> > again."
> > 
> > is consistent with the behavior associated with the udev issue that I
> > referenced earlier.
> > 
> > Have you run the two steps that are on the udev web page
> > (http://fedora.redhat.com/docs/udev/)?
> > 
> 
> The udev problem has been solved (at least for me) for some time now.
> If the system is up to date as mine is, the steps to fix the udev issue
> should not be required.
> 
> Since I installed this system I immediately did an update, then
> installed the nvidia driver and had no difficulties at all.

Jeff,

It is quite possible.

Some time ago, I ran the commands below and that solved exactly the
problem that Neal appears to be having presently.

After running these (just once), the problem was resolved and I have not
had a recurrence through several udev updates, kernel updates and nVidia
driver updates.

Thus, I have no data to suggest that this is no longer required, other
than trying to interpret Neal's problem based upon prior experience.

> > If not, go ahead and run them as 'root' in a console:
> > 
> > cp -a /dev/nvidia* /etc/udev/devices
> > chown root.root /etc/udev/devices/nvidia*
> > 
> > 
> > Then re-run the nVidia installer.
> > 
> > Now try a re-boot cycle and see what happens. It should boot into X
> > without problem if the udev issue is in fact the etiology of your
> > problem.
> > 
> > If you do not or have not run the above two steps, you will need to re-
> > install the nVidia driver every time you re-boot, not just when booting
> > a new or different kernel.
> > 
> > I am guessing that the udev related nVidia issue is not resolved via the
> > latest udev updates, which suggests that this may be an nVidia installer
> > issue and not a Fedora issue. Thus, there would not be a fix coming in
> > udev.
> > 
> 
> It sure seems fixed for me.

Again, there seems to be conflicting information here, without a clear
etiology of the problem. The fact that the related Bugzilla entry on the
udev page is crossed out would lead one to believe that the fix is no
longer required.

However, it would seem reasonable to consider that this would be
explicitly stated on that page. It is not, that page was last updated on
March 30, 2005 and the instructions are still present without
qualification, which leads me to believe that it is still required.

It seems subject to interpretation at this point.

Thanks,

Marc



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]