[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anyone have the Nvidia driver working in 2.6.11-1.14_FC3?



Marc Schwartz wrote:

On Wed, 2005-04-13 at 19:53 -0400, Neal Wilkinson wrote:


Marc Schwartz wrote:





Neal,

A possibly dumb question, but as they say the only stupid question is
the one that goes unasked.

When you tried to install the 7174 driver as above the first time "for
the 2.6.10-1.741_FC3 kernel", had you actually booted that kernel, or
were you still running the 770 kernel?

This sounds like you were still running the 770 kernel and trying to
install the nVidia driver for the other kernel. That won't work.

You need to be running the kernel that you want to install the driver
for at the time. This is why you won't be able to use the nVidia driver
if you boot a new or different kernel relative to the last time you used
the nVidia installer.

The one inconsistency here is that usually when this situation occurs, X
won't run at all and you are left at a text console login prompt after
some initial error messages and prompts about wanting to diagnose X
problems and logs, etc.

I don't know if the Livna RPMS overcome this problem, but that may be a
possibility. Someone else here may know.

BTW, for the latest kernel, the nvidia.ko file is in:

/lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia.ko


Marc






Nope, I wasn't running 770. I did go back to 770 to check and see if it worked there which it did but then I went back to the new one. I also noticed the location was /lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia.ko/ vs lib/modules/2.6.11-1.14_FC3/kernel/drivers/video/nvidia/nvidia.ko on 770. That is why I changed it just to see if it would help. When it booted directly to the console login I'm guessing it couldn't find anything but I don't know why it then worked after installing it again. I'm still very linux challenged so I could miss something obvious I'm guessing. Thanks again.



OK, your sentence:


"When it booted directly to the console login I'm guessing it couldn't
find anything but I don't know why it then worked after installing it
again."

is consistent with the behavior associated with the udev issue that I
referenced earlier.

Have you run the two steps that are on the udev web page
(http://fedora.redhat.com/docs/udev/)?

If not, go ahead and run them as 'root' in a console:

cp -a /dev/nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*


Then re-run the nVidia installer.


Now try a re-boot cycle and see what happens. It should boot into X
without problem if the udev issue is in fact the etiology of your
problem.

If you do not or have not run the above two steps, you will need to re-
install the nVidia driver every time you re-boot, not just when booting
a new or different kernel.

I am guessing that the udev related nVidia issue is not resolved via the
latest udev updates, which suggests that this may be an nVidia installer
issue and not a Fedora issue. Thus, there would not be a fix coming in
udev.

Also, just for clarification as I am not sure that this has been
mentioned to you in this thread, since you are new to Linux. Unlike
Winders, about the only time that you need to re-boot Linux is when you
need to boot a new or different kernel. Otherwise, pretty much all other
updates can be "hot" installed without a re-boot needed.

HTH,

Marc





It works though when I reboot. I don't need to reinstall. Should I go ahead and run what you suggested? If it won't hurt anything I'll give it a shot.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]