[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Need help getting clamav working



The setup:
* Home FC3 server hosting a dozen websites + email + webmail
* sendmail + dovecot for pop3/imap/smtp
* spamassasin
* squirellmail for webmail

The problem:
* far too many virus-emails hitting my M$-Outlook users (yes I do care)
* from high praise on this list I decided to install clamav
* can't get clamav working!

What works so far:
* set yum to point to FC3 extras repo - ok
* yum install clamav - ok
* yum install clamav-milter -ok
* googled "clamav howto" and settled on
http://www.airride.net/linux/fc2+clamav-howto.html as the best
* edited /etc/clam.d/milter.conf to remove "example"
* added INPUT_MAIL_FILTER(`clamav',`S=local:/var/run/clamav-milter/clamav.sock,F=,T=S:4m;R:4m')dnl
to sendmail.mc
* m4 the .mc file and restarted sendmail
* chkconfig --level 2345 clamav-milter on
* chkconfig --level 2345 clamd.milter on
* service clamav-milter start - [OK]
* service clamd.milter start - [OK]
* verified all settings above took effect

I let that sit overnight and had no log reports so I forwarded an
email with attached virus.zip nasty to myself, it was delivered to me
normally and there is no clamav log file or header info indicating it
was scanned like spamassasin adds.

The question(s):
* clamav doesn't appear to be doing anything to emails, including
virus-laden ones, what am I missing?
* there are lots of references to "freshclam" to automatically update
but "yum install freshclam" doesn't work and I can't find anything by
that name installed on my system. How to ensure proper updating?

After many days of research and trial-and-error I turn to the list and
the experts...

Thanks in advance for any help,
bob


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]