[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Need help getting clamav working



Bob Brennan wrote:
On 4/15/05, Saurabh Barve <sa atmos colostate edu> wrote:

On 4/15/05, Paul Howarth <paul city-fan org> wrote:

>> Bob Brennan wrote:
>
>>>> >>Wow, that is a very old ClamAV version. You should really update
>>>> >>quickly. 0.83 is current. I see Fedora Extras you are using (you
posted
>>>> >>that in the other reply) only has the very old 0.71 version. I
highly
>>>> >>recommend to either use the repository I am using or Dag's.
>>
>>> >
>>> >
>>> > I had already tried that and hit a dependency loop that is beyond my
>>> > newbie-ness. Specifically:
>>> >
>>> > http://dag.wieers.com/packages/clamav/
>>> > clamav-0.83-1.1.fc3.rf.i386.rpm needed clamav-db
>>> > clamav-db-0.83-1.1.el3.rf.i386.rpm needs data(clamav)
>>> > clamd-0.83-1.1.fc3.rf.i386.rpm needs clamav
>>> > loop...
>
>>
>> Install them all at the same time:
>>
>> # rpm -Uvh clam*.rpm
>>
>> This bundles all the packages into the same transaction, where they are
>> able to resolve each other's dependencies.

>># rpm -Uvh clam*.rpm
>># error: File not found by glob: clam*.rpm

>>I'm smart enough to know I either need to have added dag's repository
>>(and key?) somewhere or have already downloaded the rpm files
>>somewhere. But not smart enough to know where or how. Or where to find
>>out, sorry.

-----------

Hi,

This will help you set up Dag Wieer's repository:

http://dag.wieers.com/home-made/apt/FAQ.php#B


That's the best bet yet Saurabh, thank you!

Here's what's worked (so far)
1. follow Dag's link to install apt-get
2. apt-get update
3. apt-get install clamav
4. service clamd start
5. service clamav-milter start

...and now all the config files and freshclam seems to be as
advertised so I can get on with testing and configuring.

Thanks again Saurabh, Paul, and Alexander (and Dag!)
bob


This thread got me to try and get clamav working on my machine as well.


I changed settings in sendmail.mc, and in /etc/sysconfig/clamav-milter. Here is the socket line in in /etc/sysconfig/clamav-milter:
'local:/var/run/clamav/clamav-milter.sock '


And generating the sendmail.cf file after making changes to the sendmail.c, I get this in the sendmail.cf file:
'Xclamav, S=local:/var/run/clamav/clamav-milter.sock,F=,T=S:4m;R:4m'


But when I did 'service clamav-milter start', I kept getting this error:

Starting Clamav Milter Daemon: clamav-milter: socket-addr ( local:/var/run/clamav/clamav-milter.sock) doesn't agree with sendmail.cf
[FAILED]


I don't get this. It looks to me that the path to the socket file is the same in both the files.

I then read this in a post on the clamav mailing list:

"
I had to modify this line in my /etc/rc.d/init.d/clamav-milter file:

CLAMAV_FLAGS=' --external -lo /var/run/clamav/clamav-milter.sock'
"

I tried this advice as well, but I still keep getting the same error.


Saurabh.






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]