[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: building php with oracle support



Marius Andreiana wrote:
I'm trying to build php with oracle support in FC4t2.
Is there a way to pass the with_oci8 as true parameter to rpmbuild?
Now I manually edit php.spec and define it to 1.

$ rpmbuild --with oci8


I got an error on rpmbuild as I don't know how to pass _with_oci8 parameter and
I just changed in php.spec
%define with_oci8 1

But later in spec some places use %{with_oci8} (which is true) and other use
%{?_with_oci8:oci8} which is false.

"with_oci8" and "_with_oci8" are two different macros.


Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]