[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NFS Mount Permission Denied



Tim Holmes wrote:
On Fri, Apr 15, 2005 at 12:50:54PM -0400, Tim Holmes wrote:

Good afternoon

I was just setting up one of my servers, and ran into a perplexing
problem.

I edited my /etc/fstab file and added my new mounts ie:

Srvfs-01:/home /home nfs

hard,intr



Then restarted the nfs service

nfs service needs to run only on the server not the client.


When I type

mount srvfs-01:/home

I get mount failed, reason returned by server -- permission denied

The mount above should be mount /home.



I am logged in as root on the box im working on, and im just not

sure


where to begin trouble shooting this one

Any insights would be appreciated

TIM

[Tim Holmes wrote] Good Morning Folks


I tried the above suggestions, as far as the mount command syntax, and
it still returns the same error --  here is the session transcript

login as: root
root 192 168 0 19's password:
Last login: Thu Apr 14 13:53:56 2005 from mod3teacher.mcaschool.net
[root SRVDB-01 root]# mount /home
mount: srvfs-01:/home failed, reason given by server: Permission denied
[root SRVDB-01 root]#


I hate to admit to confusion, but I am totally lost on this one.

If "/usr/sbin/showmount -e srvfs-01" shows nothing from this particular client but does show something from a different client, it's likely to be a problem at the client side. Do you have any firewall running on this client? Can this client mount any NFS shares from any other server?


Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]