[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

mdadm hangs PC with FC3 on different SATA drives



Hello

I have been using mdadm to successfully duplicate HDD's as a means of rolling out a default build to a small number of desktops.
Each desktop is enabled with software raid in FC3.

The process I used has been as such:
Build base PC - Dell Precision 370 with 2 x 80Gb HDD's.  (Disable BIOS SATA RAID Option)
Remove Sata disk 1 from Base PC's and install into 2nd PC as Sata Disk 0.
Create portitioning on 2nd PC on SATA Disk 1 identical to SATA Disk 0.  
Run mdadm /dev/md0 --add /dev/sdb1, mdadm /dev/md1 --add /dev/sdb2, ........etc
This all worked swimmingly well until....

We bought a new batch of Precision 370's which had a different make/model of HDD.
When I run mdadm /dev/md0 --add /dev/sdb1  the system just hangs.  

All the partitioning size's are identical between the two disks with type FD.

Has anyone seen this before ?  Any suggestions as to what might be causing the problem ?
This also present a problem if one of the PC's with s/w has a disk failure, we will not be able re-build the raid devices.

Kind Regards
Mark Rus


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]