[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing dependency problem



On Apr 21, 2005, Ralf Corsepius <rc040203 freenet de> wrote:

> RH has modified their libtool to accommodate RH's multiarch demands.

Actually, it's a shame that upstream libtool couldn't go with the ABI
multiarch specs distributed by AMD (AFAIK), that suggest the use of
.../lib64 for 64-bit libs and .../lib for legacy 32-bit libs, because
Debian chose to not follow that recommendation.  The end result is
that everybody is left with a somewhat-broken libtool for AMD64 by
default unless they take the trouble to modify their libtool and every
package that ships with it :-(

-- 
Alexandre Oliva             http://www.ic.unicamp.br/~oliva/
Red Hat Compiler Engineer   aoliva {redhat com, gcc.gnu.org}
Free Software Evangelist  oliva {lsd ic unicamp br, gnu.org}


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]