[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: network stalls on Fedora Core 3



Since this problem isn't a FC3 specific problem (I also discovered the same problem in the latest Ubuntu Linux), does anyone know the best mailing list/forum to that discusses kernel 2.6 and ethernet driver issues? Maybe this problem has already been identified and workarounds suggested.

I do know that this problem is not limited to a specific ethernet card. I have the same problem with both an OEM 3com ethernet card and an Intel ethernet card. I guess its possible they are the same chip inside so they are using the same driver, but I though Intel made their own network chips.



Tom Trebisky wrote:
On Sat, Apr 23, 2005 at 09:27:28AM -0700, Keith Fetterman wrote:

Tom Trebisky wrote:

I thought I would followup post since I have been having a similar problem
on my home system, and MAYBE have a clue for a solution.

...
My home system has an intel etherpro 100 NIC, and connects through some
dogmeat ethernet switch to a Cisco 678 DSL router.  These are the details,
though I don't think any are particularly relevant.

Last night I added the following entry to my /etc/sysconfig/network
file:

IPV6_NETWORKING=no
...
This was right after experiencing a stall using scp to copy a big
file to my home system.  After this, ... things seemed much better.

I will check because you might have hit it. One difference between FC3, which is the 2.6 kernel, and my RHE3 systems, which is the RH modified 2.4 kernel, might be the IPv6 settings. In the RHE3 they may be different or turned off by default, where as they may be turned on by default in FC3. I will check and retest.


I am now somewhat less enthusiastic about this, although it -seemed- to
work.  Apparently the variable to set is:

NETWORKING_IPV6=no (not IPV6_NETWORKING) -- I just reported verbatim what
some other poster advised, but a look at /etc/rc.d/init.d/network shows
that NETWORKING_IPV6 is the relevant variable, so it isn't clear how setting
IPV6_NETWORKING could do anything at all -- just a placebo ... sigh.

And reading the posts about slow network and IPv6 issues indicate this is
primarily a DNS thing, not something that would slow down or stall an
existing TCP connection (which is what I am seeing).  see:

http://weblogs.mozillazine.org/darin/archives/005753.html

To really kill ipv6 it is recommended that the following be added to
/etc/modprobe.conf and then REBOOT (just restarting the network won't
yank the ipv6 modules out of the kernel).

alias net-pf-10 off
alias ipv6 off

Then to check if ipv6 is really gone, do ifconfig -a and verify
that no ipv6 address is assigned to your network interface.

This is as much as I have learned.  There definitely is something amiss
as far as TCP connections stalling now and then, and it really is a
kick in the head when it happens in the middle of editing a long email
like this one (knock on wood).  At first I suspected my ISP (now changed
for other reasons), then I suspected my wireless access point/switch
(now bypassed) -- but it seems to trace to fedora core 3, a fellow at
work reports that he is seeing similar incidents in the same timeframe
(i.e. as of the 2.6 kernel).  It would be better if the connection would
timeout and fail rather than stall and deadlock.

Tom



--
-----------------------------------------------------------------
Keith Fetterman                          206-780-5670
Mariner Supply, Inc.                     kfetterman go2marine com
http://www.go2marine.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]