[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: squid folder permissions



Am So, den 24.04.2005 schrieb David Niemi um 2:19:

> I am trying to setup squid as a transparent proxy server / accelerator
> and instead of using the default /var/spool/squid I'd like to
> use /tmp/spool/squid.  I'd like to use this drive as I have a lot more
> frees space.
> 
> When I set the cache_dir in the squid.conf file then issue "squid -z"
> there is this error in the log file:
> 
> 2005/04/23 23:16:06| /tmp/spool/squid: (13) Permission denied
> FATAL: 	Failed to verify one of the swap directories, Check cache.log
> 	for details.  Run 'squid -z' to create swap directories
> 	if needed, or if running Squid for the first time.
> Squid Cache (Version 2.5.STABLE9): Terminated abnormally.
> 
> I tried creating the directories and setting the same permissions and
> owners as is visible from checking the file properties with nautilus
> always with the same error.

You probably missed the SELinux context settings.

http://fedora.redhat.com/docs/selinux-faq-fc3/

Alexander


-- 
Alexander Dalloz | Enger, Germany | GPG http://pgp.mit.edu 0xB366A773
legal statement: http://www.uni-x.org/legal.html
Fedora Core 2 GNU/Linux on Athlon with kernel 2.6.11-1.14_FC2smp 
Serendipity 02:22:38 up 11 days, 23:03, load average: 0.05, 0.15, 0.16 

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]