[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: an rpm question



On Sun, Apr 24, 2005 at 08:55:58AM -0700, bruce wrote:
> i did an install/update of an rpm (openssl). it successfully placed the
> files/.so in the /usr/lib dir. i then did an rpm install/upgrade of another
> package that required the openssl libs.. the install process dies because it
> says it needs the openssl libs even though i can phisically see/verify that
> they're in the /usr/lib dir...
> any ideas as to what might be causing this issue and how i can correct it...

As I understand it, until openssl reaches 1.0, the developers aren't making
any particular effort to preserve compatibility between one version and the
next. This can makes it difficult to update, because you may need to update
a bunch of things all at once -- or, you end up with what Fedora has --
multiple packages, like openssl-0.9.7a and then the "compatibility" version
openssl096b-0.9.6b. What did you upgrade from and too? And what is the other
package that is having problems? It's hard to diagnose things like this
without details.

-- 
Matthew Miller           mattdm mattdm org        <http://www.mattdm.org/>
Boston University Linux      ------>                <http://linux.bu.edu/>
Current office temperature: 79 degrees Fahrenheit.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]