[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

starting wireless with WPA, ralink rt2500



(The correct list this time)

I'm having 'issues' getting my wireless connection started.
Once up and running it's fine (even surviving restarting the AP),
but getting it there is unreliable.

I'm using a desktop machine with EDIMAX 7128g PCI card (rt2500
chipset) and last Friday's CVS for the rt2x00 drivers, installed
using 'make install-fedora' which sets up an alias for wlan0.

The network is using WPA, so I need to use iwpriv commands
to set it up.  It seems the settings could be put in
/etc/sysconfig/network-scripts/ifcfg-wlan0, but I can't get
this to work.

What I'm doing at the moment (after some trial and error), is
to have the iwpriv commands in /root/wlan and to hit the
system-control-network start for the wireless connection
and (after a short delay), run '. wlan' as root:

ifcfg-wlan0:
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=no
USERCTL=yes
PEERDNS=yes
#modified line:
GATEWAY=192.168.2.1
#
TYPE=Wireless
DEVICE=wlan0
HWADDR=00:0e:2e:51:c5:25
BOOTPROTO=dhcp
NETMASK=
#modified line:
DHCP_HOSTNAME=ibm21
#
IPADDR=
DOMAIN=
ESSID=thessid
CHANNEL=7
MODE=Managed
IWPRIV="set EncrypType=TKIP set WPAPSK='thekey' set TxRate=0"


/root/wlan: iwconfig wlan0 mode managed iwpriv wlan0 set AuthMode=WPAPSK iwpriv wlan0 set EncrypType=TKIP iwpriv wlan0 set WPAPSK="thekey" iwpriv wlan0 set TxRate=0


Some observations: The IWPRIV line in ifcfg-wlan0 was manually added and is wrong, these commands should be seperate. However I've also tried them as seperate IWPRIV="" lines with no more success. If someone can suggest something else to do with them I'd be happy to try. There is also the question of whether or not the key should be quoted. I'm not sure I've tried all the options, but I think the card only associates with the network when the key is right so that's not too hard to spot.

The card does not always seem to be 'on' when the system starts up:
#iwlist scan
won't show any networks (there are several).  I haven't been able to
reliably start it yet (I've tried 'ifconfig wlan0 up' as some of the
howtos suggest this needs to be run before the card accepts any iwpriv
or iwconfig commands).  lsmod always shows the rt2500 module.  After
sufficient tries it will seem to wake up, and iwlist scan will show
the available networks.

The fact that running the wlan script concurrently with an ifup wlan0
seems to be required suggests there's something funny about the order
of the commands/options in ifcfg-wlan0.  I've also noticed the Tx/Rx
lights come on once '. wlan' has been run.  Does anyone have any
suggestions about this?  Does the order the options are listed even
make a difference to the order they are run in?  I'd like to get
ifcfg-wlan0 working properly so I can set it to connect on boot but
atm this isn't going to happen.

Any thoughts appreciated.

imalone


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]