[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC3 and ATI Digital video



On Sun, 2004-11-14 at 15:39 -0500, Gene Czarcinski wrote: 
> Question:  Is anyone using digital (DVI) video, an ATI video card and the 
> radeon driver?  Does it work?  IS anyone having problems?

I am (attempting to) run an 128MB DDR ATI AIW Radeon 9700 PRO, 

driving an APP9217 Apple 17" Studio Display (ADC(DVI)) LCD panel
(1280x1024x24),
which is correctly detected:

(II) fglrx(0): EDID data from the display on Primary head
----------------
(II) fglrx(0): Manufacturer: APP  Model: 9217  Serial#: ........
(II) fglrx(0): Year: 2001  Week: 25
(II) fglrx(0): EDID Version: 1.2
(II) fglrx(0): Digital Display Input
(II) fglrx(0): Max H-Image Size [cm]: horiz.: 33  vert.: 27
(II) fglrx(0): Gamma: 2.35
(II) fglrx(0): DPMS capabilities: Off; RGB/Color Display
(II) fglrx(0): redX: 0.631 redY: 0.351   greenX: 0.301 greenY: 0.570
(II) fglrx(0): blueX: 0.141 blueY: 0.096   whiteX: 0.311 whiteY: 0.330
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 108.0 MHz   Image Size:  337 x 270 mm
(II) fglrx(0): h_active: 1280  h_sync: 1408  h_sync_end 1520 h_blank_end
1688 h_border: 0
(II) fglrx(0): v_active: 1024  v_sync: 1028  v_sync_end 1031 v_blanking:
1066 v_border: 0
(II) fglrx(0): Monitor name: Apple Studio
(II) fglrx(0): Monitor name: Display
(II) fglrx(0): 
(II) fglrx(0): DesktopSetup 0x0000
(**) fglrx(0):  PseudoColor visuals disabled
(**) fglrx(0): Overlay disabled
(**) fglrx(0): Overlay disabled
(II) fglrx(0): PLL parameters: rf=2700 rd=12 min=20000 max=40000
(==) fglrx(0): Using gamma correction (1.0, 1.0, 1.0)
(**) fglrx(0): Center Mode is disabled 
(==) fglrx(0): TMDS coherent mode is enabled 
(II) fglrx(0): Panel size found from DDC: 1280x1024
(II) fglrx(0): Total 1 valid mode(s) found.
(--) fglrx(0): Virtual size is 1280x1024 (pitch 1280)
(**) fglrx(0): *Default mode "1280x1024": 108.0 MHz (scaled from 0.0
MHz), 64.0 kHz, 60.0 Hz
(II) fglrx(0): Modeline "1280x1024"  108.00  1280 1408 1520 1688  1024
1028 1031 1066
(--) fglrx(0): Display dimensions: (330, 270) mm
(--) fglrx(0): DPI set to (98, 96)

This monitor is connected to a Dr. Bott's DVIator to provide power,
and split from the proprietary ADC connector to the standard
DVI and USB connectors. The DVI connector is fed from the primary port
on an ATI Radeon 9700 Pro All-In-Wonder, a DVI connector.

The MoBo is an Asus A7N8X-E, replacing a previous A7N8Xdeluxe2.0,
both based on nVidia nForce2 chipset.
The A7N8X-E has only ever had Fedora Core 3 on it.
The A7N8Xdeluxe2.0 had Fedora Core 1 after RedHatLinux9pro.
The transition between FC1 & FC3, 
and between deluxe2 & -E coincided.

CPU: AMD Barton .13u core AthlonXP 3000+ 333MHz FSB 
512K L2 / 128K L1 Cache

2 * 512MB Kingston HyperX PC3500 DDR433 CL2 SDRAM DIMM

2 * 120GB SATA/150 Seagate Barracuda 8MB Cache 7200.7 Plus 

Ignoring the change of the 2nd Ethernet port between MoBo's,
the need for proprietary nVidia drivers for the 2nd Ethernet port and
the audio subsystem, and the particular problems of driving the Seagate
SATA drives from the SiI3112 controller, fundamentally the video system
hardware is unchanged. All installs (RH9, FC1, FC3) were done in text
mode. The console mode has always worked. The DPMS has never worked,
therefore I've resorted to using an external plug strip to shut down the
power supply for the LCD panel when I want it off. 

OK... with the context in place, we can get down to the issues at hand.

I have ONLY every had success getting X11 configured for this system
automatically by KNOPPIX. Up through FC1, I could manually hack the
XF86Config it produced to work with my RH/FC software. With the
"up"grade to FC3 including the transition to X.org, I've been
unsuccessful getting into graphics mode. 

I've tried on FC3 both the system-config-display and fglrxconfig.
I've tried to install ATI's fglrx and Radeon drivers...
the Radeon is incompatible, the fglrx installs but fglrxconfig produces
unworkable configs.

The usual result of "startx" is a powered-down screen.

Either DPMS works but it will not turn on and work,
or if it turns on and works, it will not power down.

So, for now, I run the latest FC3 software over my LAN using an Xserver
on my YellowDog2.3 box.

Running the video config scripts over that link has not produced
workable configs. 

What changed between XFree86 and X.ORG?

So, I can finally nearly repeat the original question...

Has anyone successfully got an ATI video card driving DVI LCD on FC3?

The latest configs and logs at 
http://www.kahealani.net/xorg/?C=M;O=D

-- 
All rights reserved without prejudice. All information and transactions
are non negotiable and are private between the parties.  Copyright 2005
Angela Kahealani. http://www.kahealani.com/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]