[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mouse Configuration



On Tue, 2005-26-04 at 09:31 -0600, Adam Burke wrote:
> I am still unsure about how to go about changing the button
> configuration for my mouse, and i get the same error that Harlan gets
> when entering in the code you suggested.  Any other ideas?

Hi,

I have an Intellimouse Optical USB and PS/2 compatible and eventually
got it working like so:

In /etc/X121/xorg.conf:

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "ExplorerPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "Buttons" "7"
	Option	    "Emulate3Buttons" "no"
	Option	    "ZAxisMapping" "6 7"
EndSection

Note that my z-axis mapping is different from Alexander Dalloz and I'm
not doing three-button emulation, though I'm not sure that matters.

I seem to have the same pointer mapping:

$ xmodmap -pp
There are 7 pointer buttons defined.

    Physical        Button
     Button          Code
        1              1
        2              2
        3              3
        4              6
        5              7
        6              4
        7              5

I should mention that it took me awhile to find a procedure that worked.
Googling eventually brought me to:

http://gentoo-wiki.com/HOWTO_Mouse_Nav_Buttons

which goes into more detail. Worth a look.

Good Luck!

Jeff



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]