changing default gcc include path

Chris Jones jonesc at
Thu Dec 1 14:56:58 UTC 2005


I've fixed my problems with python, and now the applications compile fine. 
However, I run into a problem when trying to execute the applications. Just 
to clarify, what I want to try and do is to be able to work with applications 
developed primarily on slc3 systems with gcc 3.2.3 on FC4. If I just run the 
binaries that where built on slc3 on fc4, with the compat libraries installed 
all seems OK. However, if I try and build one of the component libraries on 
fc4 (again using the gcc 3.2.3 compat), when I run I get the following crash

 Generating stack trace...
 0x01de64f2 in __gnu_cxx::__pool<true>::_M_reclaim_block(char*, unsigned int) 
+ 0x8c from /usr/lib/
 0x01de68d3 in <unknown> from /usr/lib/
 0x01e2c8b4 in std::basic_string<char, std::char_traits<char>, 
std::allocator<char> >::_Rep::_M_destroy(std::allocator<char> const&) + 0x2e 
from /usr/lib/
 0x01e2dee3 in std::basic_string<char, std::char_traits<char>, 
std::allocator<char> >::assign(std::basic_string<char, 
std::char_traits<char>, std::allocator<char> > const&) + 0xa3 
from /usr/lib/
 0x0407210d in 
std::char_traits<char>, std::allocator<char> > const&, 
std::basic_string<char, std::char_traits<char>, std::allocator<char> > 
const&, IInterface const*) + 0xf9 
from /home/jonesc/cmtuser/Rich/RichTools/v1r8/slc3_ia32_gcc323/

where is the library I built. The problem seems to be with - The libraries built on slc3 do not use this dll, only, which is why they run fine.

So, Is there something wrong with my build or linking ? Do I for example need 
some other versions of binutils etc. ? Is what I am trying to do just 
impossible ?

thanks for any advice.


p.s. I am well aware the nicest solution would be to port the applications to 
a new gcc version, such as 4. Unfortunately this is beyond my control :)

More information about the fedora-list mailing list