Problem booting after Yum update of FC4

Tony Foster Tony_Foster at
Fri Dec 2 07:09:34 UTC 2005

I was Running FC3 on a PC platform ( 64 bit Intel P4 Prescott 630 in Foxconn
mother board). When I tried to upgrade the FC with rpm I had trouble with my
network timing out. 
Disc is a SATA drive 
Root file system is LVM 

I decided to upgrade to FC4. I did a clean install and formatted the disc
I turned on Samba and few other minor configuration updates. (reinstalled my
user directory to get my email back) 
I did run find from root without any failures. 

I tried to update with RPM but the network timed out. I  am having the same
network time outs on my wife's Mac and a new wintel XP laptop. 

I switched to Yum and the update proceeded smoothly but took 3 hours. 

Here is where the problems start. 
I was searching for HelixPlayer to see if it was on the system. 
Find returned an error 
	" incorrect hard link count in /proc usually a disc driver problem" 
I decided to reboot to see if the disc would run FSCK. 
The boot process hung at the same place 2  
	starting network loopback 

I stopped the boot the next time and reverted to the old kernel believing
that the disc drivers are in the kernel. (June FC4 install discs ) 
This worked and the system boots. Appears to be fully functional. 
I tried a "find" and got the same file system error in /proc directory. 

So I thought I would check if this is a known problem. 

I assume next steps would be to run FSCK on root disc. ( I do not have
experience with LVM and FSCK) 

I would like any advice on trouble shooting which update is causing the
I wanted the FC4-64bit see if there was a performance difference. 
I can go back and reinstall FC and manage the Yum update more tightly. 

Tony Foster

Cell  916 300 7701 
Tony_Foster at

"Any sufficiently advanced technology is virtually indistinguishable from
(Arthur C. Clarke)

More information about the fedora-list mailing list