FC3 USB Hard drive - large file corruption

Robert Paxton rpaxton at myeserver.com
Sun Dec 4 18:53:54 UTC 2005

I am experiencing a problem on my FC3 file server with large files (1gb and
larger) being corrupted when transferring the files to a usb drive over the
network. I can transfer the same set of files to the internal hard drive
over the network with no problems. I can transfer the same set of files from
the internal hard drive to the usb drive with no problem. I have transferred
the files from a Windows XP machine and a Windows 2000 machine with the same
sort of corruption occurring. The problem only occurs when transferring the
files across the network to the usb drive. I have transferred the files to
the usb drive with both a samba share and through sftp with file corruption
occurring with both types of transfers. 


This problem does not occur on the same machines when running FC1. I
transferred a 3.5gb set of smaller files ranging in size from 8k to 3m with
no file corruption. This problem only appears to occur with large files. I
have two different machines which I have tried this with. One is a Pentium
900 and the other is a AMD2200. Using a control group of 17 files and
running the transfer multiple times I have found out the corruption occurs
in different places on different files each time. Three or four files will
be corrupt when transferring to the AMD2200 machine while tweleve to
seventeen of the files will be corrupt on the Pentium 900 machine. This
problem does not occur when I run FC1 on these machines, but does occur when
running FC3. I have tried this with several different brands of usb drives
with the same results.



Anyone have any idea why this is happening?


Robert S. Paxton

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/fedora-list/attachments/20051204/c1740f6d/attachment-0001.htm>

More information about the fedora-list mailing list