up2date wrong version after updating to fc4.

Paul Howarth paul at city-fan.org
Tue Dec 6 08:30:37 UTC 2005

On Tue, 2005-12-06 at 01:08 -0700, Kim Lux wrote:
> I've got a problem with up2date after upgrading an FC3 server to FC4.
> I installed the new rpms spoken of at the bottom of this email. 
> I've edited the sourcesConfig.py file, changing releasever from "3" to
> "4".
> I ran up2date --upgrade-to-release=4
> I also ran up2date --register

No need to do that.

> When I run up2date from the command line, I get:
> Repository extras already added, not adding again
> Repository updates-released already added, not adding again
> Repository base already added, not adding again

Let's try to fix this first. You have multiple repository definitions
for the extras, updates-released, and base repositories, which probably
means that your existing FC3 repo definitions are still active. I'd
guess that you have them in /etc/yum.conf, whereas they are specified in
separate files in directory /etc/yum.repos.d in FC4. Try
editing /etc/yum.conf and removing the entries for these three
repositories from there.

(Note: in FC4, up2date uses repository information from yum by default)

Paul Howarth <paul at city-fan.org>

More information about the fedora-list mailing list