MP3 playing stopped working

Amadeus W. M. amadeus84 at
Sat Dec 10 14:59:01 UTC 2005

On Fri, 09 Dec 2005 23:09:16 +0000, pat wrote:

> Hello All,
> I followed the un-offical FAQs (going through freshrpms) to get mp3s working on
> FC4 and was quite happy.   Last week I found things not working- no songs showed
> up in rhythmbox & xmms would only pop up a file selector when I tried to play a song.
> I tried going to the previous versions of ffmpeg & tried re-running gst-register.
>  I tried updating gstreamer by adding the gstreamer repository to my yum.conf.  I
> tried installing amorok.  It has driven me to drink!
> While the drink is certainly helping, I don't know where to go now.  Where should
> I look to find out more about this problem?  
> Thanks in advance
> -Patrick

The first question is, do you have sound at all, or is it just
playing the mp3s? 

If you have the livna repository enabled, install mpg321 (and dependencies):

yum install mpg321

Then, at a command prompt:

mpg123 files.mp3        # or mpg123 files*.mp3

If this doesn't play it, the mp3 file is corrupt, or you have troubles
with the audio device. Try to play an audio cd then, and see what happens. 

More information about the fedora-list mailing list