Firefox 1.5 [installation problems -- x86-64 issues?]

Jonathan Ryshpan jonrysh at
Tue Dec 20 00:11:20 UTC 2005

On Fri, 2005-12-16 at 14:18 -0500, Tayfun Can wrote:
> has one for FC4
> On 12/11/05, John Francis <john.francis at> wrote:
>         So are we going to see Firefox 1.5 released for FC4?

I have downloaded the version of firefox available from,
and am attempting to install it.  An initial installation attempt
produces errors:
        # rpm --upgrade --test
        error: Failed dependencies:
       is needed by
       is needed by

I assume libcairo and libpangocairo are parts of the cairo rpm, but an
attempt to download cairo from the Fedora development repo using yumex
produces further errors:
        Parsing package install arguments
        ['Unable to satisfy dependencies', 'Package glibc-devel needs
                = 2.3.5-10.3, this is not available.', 'Package
                glibc-devel needs glibc-headers = 2.3.5-10.3, this is
                not available.']
        Excluding Packages in global exclude list

These errors are truly perplexing since glibc-devel is already
installed, and the desired versions of glibc and glibc-devel appear to
be installed.  (Since I am running on an x86-64 system, many rpms appear
        # rpm -q glibc glibc-headers glibc-devel

Any ideas what's going on?

Thanks - jon

More information about the fedora-list mailing list