[fedora-java] Eclipse and Tomcat - where?

Daniel B. Thurman dant at cdkkt.com
Tue Dec 20 18:59:59 UTC 2005

>From: Andrew Overholt [mailto:overholt at redhat.com]
>Sent: Tuesday, December 20, 2005 10:29 AM
>To: Daniel B. Thurman
>Cc: Gary Benson; Fedora Java Development List (E-mail)
>Subject: RE: [fedora-java] Eclipse and Tomcat - where?
>On Tue, 2005-12-20 at 09:48 -0800, Daniel B. Thurman wrote:
>> >From: fedora-devel-java-list-bounces at redhat.com
>> >[mailto:fedora-devel-java-list-bounces at redhat.com]On Behalf Of Gary
>> >Benson
>> >Sent: Tuesday, December 20, 2005 9:12 AM
>> >To: Fedora Java Development List (E-mail)
>> >Subject: Re: [fedora-java] Eclipse and Tomcat - where?
>> >
>> >
>> >Daniel B. Thurman wrote:
>> >> Hi Folks,
>> >> 
>> >> I finally am ready to test by application on Fedora using Eclipse
>> >> and I am at the point where I am trying to run my web-application
>> >> using Tomcat.
>> >> 
>> >> Of course, the Tomcat dialog box pops up and asks where the
>> >> Tomcat installation directory is.... ugh....  I have NO CLUE!
>> >> 
>> >> On windows, Tomcat is installed by Eclipse so I dont have to
>> >> figure this out....  but on Fedora, seems like I do.
>> >> 
>> >> Can someone tell me what to do?
>> >
>> >Well, I don't know what dialog box this is, but on Fedora the Tomcat
>> >installation directory (CATALINA_HOME) is /usr/share/tomcat5/.
>> >
>> >Cheers,
>> >Gary
>> >
>> Hmmm.. ok, so I have that - but this did not help.
>> The specific dialog box appears when you attempt to run the
>> web-application project (RunAs->Run on Server) and you
>> are then to choose the application server (tomcat 4,5,5.5)
>> and provide the tomcat installation directory otherwise
>> you cannot run the application.  I entered the pathname of
>> /usr/share/tomcat5 and it does not allow me to continue.
>> I tried different tomcat versions (5.0, 5.5) and neither
>> worked.
>> So- I am stuck - and cannot even get my application to run
>> at this time.  Any ideas?
>Is it trying to launch tomcat itself?  That won't work as it's supposed
>to run as root (or the tomcat user or whatever).

Tomcat is a java servlet application server and yet developers
using eclipse are doing development work so why should it be a
"root" requirement to run and/or start it? Sure beats me...

But in any case and from what I can tell, no matter what I enter into
the "Tomcat installation directory" textbox, the eclipse program
keeps saying that the directory provided is not a valid tomcat installation
directory and will not allow me to continue.  I have used eclipse on windows
for awhile and tomcat (or other server) selections runs fine - "root" or not
and it even "installs" the server (along with Sun's version of their app server
w/ DB support) which makes it pleasant for developers so why not follow the same
pathway for linux-based developers? Why force configuration make us jump through
hoops when all "we" care about is to develop applications? I *should* be able to
choose *any* AS with Eclipse under Linux?

Anyone care to jump in and tell me how to get tomcat started under
Eclipse's control?


>No virus found in this incoming message.
>Checked by AVG Free Edition.
>Version: 7.1.371 / Virus Database: 267.14.1/207 - Release 
>Date: 12/19/2005

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.1/207 - Release Date: 12/19/2005

More information about the fedora-list mailing list