fc4 yum update problems on two installations

sport sport-light at sbcglobal.net
Tue Dec 20 14:07:31 UTC 2005

I have three machines all 32 bit running fc4.  These machines have been
up and running without problems for five months or so.  I ran yum update
on a one machine last sunday dec. 18th, and yum eventually failed with a
segmentation fault.  I rebooted the machine, and kde won't come up.
With the root login I was able to run gnome, and successive yum clean
all, yum updates failed.  On a second machine I tried yum update on
monday the 19th, and yum failed in a similar fashion, and repeated
attempts caused rpmdb 4096 Input/output errors.  On a third machine I
ran yum update on the 14th with success, and am afraid to attempt it
again.  It appears as though yum was updated in each of these.  

The yum.log is blank on machine #2.  I have run yum remove kernel
2.6.4-1.1653_fc4 on this machine, and yum makes it through, but
complains about rpmdb errors.  Running yum update
kernel-2.6.4-1.1653_fc4 completes, and says that the kernel was
installed, but also complains of the rpmdb errors.  It does add the
kernel, but the machine fails to boot on that kernel.

Does anyone know of changes made last week to some packages, possibly
yum or rpm that could be causing this?  The problem occurring on two
separate systems and only when yum update was run in the last few days
makes me think there is some new issue with the update mechanism.

I would appreciate any comments.


More information about the fedora-list mailing list