fc4 yum update problems on two installations

sport sport-light at sbcglobal.net
Tue Dec 20 16:08:00 UTC 2005

Thanks Aaron.  

Erasing the database files, and then rebuilding them appears to have
made a difference.  I am no longer getting the rpmdb errors, and running
yum update apparently installed some sql packages cleanly.  The problem
now seems to be that yum thinks some packages are up to date when they
are not.  For instance, the kernel should be 2.6.4-1.1653, and the
latest installed is xxx.1637.  I believe since yum barfed early on in an
update for the period from November to yesterday, many of the packages
did not get completely updated.  KDE is not current, because yum never
made it past installing it, but the "yum update" command doesn't try to
install either the latest kernel or KDE.

Do you know how to get yum to force update everything?  I think I better
do something like this to make sure everything gets cleanly updated.

I am currently reading through the yum docs to find out how to do this
as well.


On Tue, 2005-12-20 at 16:24 -0600, akonstam at trinity.edu wrote:
> On Tue, Dec 20, 2005 at 02:07:31PM +0000, sport wrote:
> > I have three machines all 32 bit running fc4.  These machines have been
> > up and running without problems for five months or so.  I ran yum update
> > on a one machine last sunday dec. 18th, and yum eventually failed with a
> > segmentation fault.  I rebooted the machine, and kde won't come up.
> > With the root login I was able to run gnome, and successive yum clean
> > all, yum updates failed.  On a second machine I tried yum update on
> > monday the 19th, and yum failed in a similar fashion, and repeated
> > attempts caused rpmdb 4096 Input/output errors.  On a third machine I
> > ran yum update on the 14th with success, and am afraid to attempt it
> > again.  It appears as though yum was updated in each of these.  
> > 
> > The yum.log is blank on machine #2.  I have run yum remove kernel
> > 2.6.4-1.1653_fc4 on this machine, and yum makes it through, but
> > complains about rpmdb errors.  Running yum update
> > kernel-2.6.4-1.1653_fc4 completes, and says that the kernel was
> > installed, but also complains of the rpmdb errors.  It does add the
> > kernel, but the machine fails to boot on that kernel.
> > 
> > Does anyone know of changes made last week to some packages, possibly
> > yum or rpm that could be causing this?  The problem occurring on two
> > separate systems and only when yum update was run in the last few days
> > makes me think there is some new issue with the update mechanism.
> > 
> > I would appreciate any comments.
> > 
> > Thanks,
> > Chris 
> -- 
> n one of the machines I would run this experiment, Erase :
> /var/lib/rpm/__db.*
> Then I would run rpm --rebuilddb
> and see if things get better.
> =======================================================================
> What this country needs is a good five cent microcomputer.
> -------------------------------------------
> Aaron Konstam
> Computer Science
> Trinity University
> telephone: (210)-999-7484

More information about the fedora-list mailing list