change in launcher behavior from FC3 to FC4

Richard England rengland at
Wed Dec 21 23:30:41 UTC 2005

Dave Perry wrote:

> I just did an upgrade install of FC4 over FC3 on my Dell Latitude 
> notebook.  I can add launchers for programs that I installed from RPMs 
> and they work.  But if I add a launcer for a program that I compiled 
> (./configure && make && Make install), the launcer dos not work.  I 
> select "Run in terminal" and the terminal window flashes for a 
> fraction of a second and the app dies.  Same exact response if I use 
> "Run Application".  The particular app is "fgrun", a gui front end for 
> FlightGear.  If I just type "fgrun" in a terminal, the app launhces, 
> but the launcher does not work whether I put it in a pannel or on the 
> desktop.  This worked fine under FC3 on the same notebook.  I just 
> tried several other non RPM compiled apps and got the same results.  
> Any ideas what changed from FC3 to FC4 that could cause this?  Yes, I 
> updated FC4 with a very lengthy "yum update".
> Thanks in advance for any help.
> Dave P.
Did you give a fully qualified path name to "fgrun" in your launcher or 
just the command "fgrun"?   Where was fgrun installed?  If it is not in 
a location referred to in your PATH environment variable, it may not be 
seen in the launcher....


More information about the fedora-list mailing list