stumped! nvidia-glx = 0:1.0.7676 needed, but shows as installed...

Patrick Barnes nman64 at n-man.com
Sat Dec 24 21:30:02 UTC 2005


B Wooster wrote:
> yum update is failing on my FC3 system today.
>
> Error is this:
> Error: Missing Dependency: nvidia-glx = 0:1.0.7676 is needed by
> package kernel-module-nvidia-2.6.12-1.1380_FC3
>
> But why does it want to update that, from what I can tell, it is
> already installed, here's what yum list shows:
> Installed Packages
> kernel-module-nvidia-2.6.12-1.1380_FC3.i 1.0.7676-0.lvn.2.3     installed
> nvidia-glx.i386                          1.0.7676-0.lvn.2.3     installed
>
>
> Any ideas on what I should try to get around this dependency failures?
> uname -a is:
> 2.6.12-1.1380_FC3 #1 Wed Oct 19 20:34:13 EDT 2005 i686 athlon i386 GNU/Linux
>
>   
It looks like one of these two packages is trying to update without the
other.  For example, as long as you have
kernel-module-nvidia-2.6.12-1.1380_FC3-1.0.7676-0 installed, you cannot
update nvidia-glx-1.0-7676-0 to a newer version.  If you try to update
nvidia-glx, then it will say that the old version is needed for the
kernel-module-nvidia package you have installed.  Try removing that
kernel module, updating your system, and then installing the latest
kernel-module-nvidia (if needed).

-- 
Patrick "The N-Man" Barnes
nman64 at n-man.com

http://www.n-man.com/
-- 
Have I been helpful?  Rate my assistance!  http://rate.affero.net/nman64/


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
URL: <http://listman.redhat.com/archives/fedora-list/attachments/20051224/efc68ffe/attachment-0001.sig>


More information about the fedora-list mailing list