FC4 up2date fatal RPM install error

David L idht4n at hotmail.com
Mon Dec 26 19:02:16 UTC 2005

I just tried to run up2date on my FC4 system and got an error during 

There was a fatal RPM install error.  The message was:
There was a rpm unpack error installing the package: 

I selected the only available option - "OK" and it exited up2date (it didn't 
just abort installing that one package).  So I tried to run up2date again 
and it found one new package to download (presumably one that was changed 
during the 2 hours I had been running the previous up2date).  It installed 
that new package, but didn't continue installing other downloaded packages 
where it left off.  Now I suspect I have a half updated system.  Some of the 
packages that were updated no longer work... for example thunderbird no 
longer works.  How do I recover from this?



PS - It seems like I get errors every few times I run up2date... every 6 
months or so they're bad enough that my install is no longer useful.  
Fortunately that's about how often new releases come out, so I usually just 
install the new release.  But I think it's about time I learn whatever magic 
is required to overcome up2date problems.  Do I just have bad up2date karma 
or is it as fragile as it seems to me?  My computer at work and my computer 
at home are both currently broken wrt up2date.  :(

Express yourself instantly with MSN Messenger! Download today - it's FREE! 

More information about the fedora-list mailing list