status of Palm Sync

David L idht4n at
Tue Dec 27 15:29:03 UTC 2005

>On Tue, 2005-12-27 at 00:23 -0800, David L wrote:
> > > > I just bought a Treo 650 and was looking for info about how to use 
> > >with
> > > > FC4 when I found the posting below which says FC4 is "completely 
> > >with
> > > > respect to Palm syncronization".  Is this supposed to be addressed 
> > >FC5,
> > > > or should I "downgrade" to FC3?  Has anybody synced a Treo with
> > >Evolution in
> > > > FC5-test1?
> > >
> > >Palm syn still broken. The latest packages might have solved the 
> > >for a couple of people, but at least in my case, I still need Mark G.
> > >Adams' RPMs (see below) to get my Palm to sync.
> > >I've given up on bug-reports.
> > >Last time I counted, I found ~10 bugs related to udev ttyUSB, pilot-*
> > >and gnome-pilot)
> > >
> > >I'm using the fix from:
> > >
> > Hmm... This didn't seem to work for me.  Installing the rpms like it
> > indicated in the readme (it said rpm -Fvh *.rpm) acted like it didn't
> > actually install anything.  So I just extracted the files from the rpm 
> > like this:
> > rpm2cpio /tmp/pilot-link-0.12.0-0.pre4.0.fc4.2.i386.rpm | cpio -i -d
> >
> > Then I added the path to the usr/bin directory that the above command
> > extracted to the beginning of my path.  I pushed the hotsync button and 
> > ran:
> >
> > pilot-xfer -p /dev/ttyUSB1 -b /tmp/foo2
> >
> > I ran this several times until udev got around to creating ttyUSB1, but 
> > it just sat there doing nothing until the Treo timed out.  I also tried
> > coldsync with the same results:
> > coldsync -p /dev/ttyUSB1 -mb /tmp/foo2
> >
>Two things.
>A. I installed the RPMS using "rpm -Uvh" and they installed just fine.
>Installing RPMs using cpio is usually a bad thing(c).  I'd suggest you
>uninstall the current RPMs and reinstall them.
OK --- I ran "rpm -ivh --replacepkgs --replacefiles pilot-link*.rpm" and it 
seemed to install those packages ok.

>B. I created a /etc/dev directory and created the two ttyUSB0/1 nodes by
>hand, pointing all pilot devices to the static device entries. This
>solves all udev problems.

This worked!  It was weird... udev seemed to be creating the nodes (although 
it took a little while), but when I statically create the device entries, 
pilot-xfer is much happier.  So far, all I've done is back up, but that's 
finally working.  :)  Now I'll try more complicated things like evolution 



Express yourself instantly with MSN Messenger! Download today - it's FREE!

More information about the fedora-list mailing list