FC4 up2date fatal RPM install error

Jim Cornette fc-cornette at insight.rr.com
Wed Dec 28 00:51:42 UTC 2005

akonstam at trinity.edu wrote:

>Why are people still trying to use up2date rather than yum in FC4.
Familiarity and features is the reason that I use up2date on a 
non-networked computer. I use yum to erase packages with dependencies, 
but up2date for the bulk of upgrading.  Up2date works well in this 
capacity and the system that I use it on has no duplicated packages or 
any errors for programs that I have tried or used.
I download the rpms via a networked computer to a SAMBA share on the 
non-networked computer and have up2date set up with local directories. I 
download rpms  frequently when notices for new packages are announced or 
if I happen to check the latest dated rpm on the samba share against the 
mirror that I check rpms on.
I believe you have to run createrepo every time your local rpm storage 
directory is updated with rpms. You do not need to do this for up2date.

At home and with an always available connection to the Internet,  I 
prefer yum with no GUI tools. The reason, up2date does not work properly 
when I tried it when FC4 was first released. Up2date works so badly 
using yum repositories,  that it was easier to learn a new update tool 
yum. (my opinion)

I used up2date for quite awhile and know the problems and strengths of 
the program, so offered advice. When Up2date crashes, it leaves the 
downloaded rpms in its spool directory. If things go well. the rpms are 
removed at the end of the transaction.


Economists can certainly disappoint you.  One said that the economy would
turn up by the last quarter.  Well, I'm down to mine and it hasn't.
		-- Robert Orben

More information about the fedora-list mailing list