where are the device video0 ;...

Amadeus W. M. amadeus84 at cablespeed.com
Fri Dec 30 14:39:42 UTC 2005

On Fri, 30 Dec 2005 08:25:26 +0100, Francois Massonneau wrote:

> On Thursday 29 December 2005 23:03, Amadeus W. M. wrote:
>> On Thu, 29 Dec 2005 19:36:43 +0100, Francois Massonneau wrote:
>> > On Thursday 29 December 2005 19:17, Amadeus W. M. wrote:
>> >> > I'm trying to install a webcam, and from what I read, I have to
>> >> > check a device named "video0", or ("video" which is a simple link to
>> >> > video0). But inside my /dev directory, I have no video? file(s) at
>> >> > all. How do I do to create one ? I run Fedora Core 4.
>> >>
>> >> mknod /dev/video0 c 81 0
>> >
>> > No, that's not the right way imho. Each time I reboot the machine, that
>> > device disapears and I have to recreate it.
>> >
>> > I read lots of messages about that, and the latest I've found says to
>> > create a  /etc/udev/rules.d/06-dvb.rules file and to add the following
>> > lines:
>> >
>> > KERNEL="dvb*", PROGRAM="/etc/udev/scripts/dvb.sh %k", NAME="%c"
>> > SYSFS{vendor}="0x109e", PROGRAM="/etc/udev/scripts/dvb.sh %k",
>> > NAME="video0"
>> >
>> > As the card is a Pinnacle Dv500, I changed the 0x109e to 0x104c, as it
>> > seems it's the vendor id of my card, but again, it's doesn't work ;-(
>> Wait a minute! What card are you talking about? Your original post was
>> about a webcam. And earlier you posted something about a Logitech
>> Quickcam. Is that not USB?
> yes, you are right. The explanation is the following : As I saw the driver I 
> tried to use with the webcam (and I have reports that say it does with such 
> webcam) didn't create the appropriate device (video0), I thought it would 
> be a good idea to add a card I had there  (the pinnacle dv500) to that 
> computer and see if that could create the video device. But narda, nothing. 
> So I removed the card, deleted the file 06-dvb.rules I created, and kept 
> only my webcam plugs in one of the two usb entry.
> So I'm back at the beginning, with the webcam which doesn't work.
> Francois
> --

I saw another post of yours regarding the webcam, and IIRC it was a usb
logitech quickcam? I have one of those too, and I got it to work with the
qc-usb driver: http://www.ee.oulu.fi/~tuukkat/quickcam/quickcam.html

I'd try to make the device manually first, even though it disappears after
a reboot, and try to configure the webcam, then I'd worry about making
/dev/video0 permanent later.

More information about the fedora-list mailing list