kppp doesn't know modem initialisation strings !

Parameshwara Bhat peebhat at
Sat Dec 31 00:55:40 UTC 2005

Hello List,

I am updated to latest (3.5) KDE from kde-redhat repository.When I run  
kppp,(sudo /usr/sbin/kppp),
set correct modem port and ISP account.It just can't dial.

When I checked in the configure dialogs,under 'modem commands',nothing is  
listed. Kppp has forgotten all the modem initialisation strings!

Now, I run it as user,again the same.No initialisation strings.I give the  
chosen modem a name,save it and go to create a new modem,all the  
initialisation strings are there.But I cannot run it as I have no access  
right to modem as a user.

I go back and sudo again.This time,with the same procedure,there is no  
luck.Kppp doesn't know anything about modem initialisation.

By the By, latest linux creates ownership for the user on all devices like  

[pbhat at sidharth ~]$ ls -l /dev/hdc
brw-------  1 pbhat disk 22, 0 Dec 30  2005 /dev/hdc
[pbhat at sidharth ~]$ ls -l /dev/fd0
brw-rw----  1 pbhat floppy 2, 0 Dec 30  2005 /dev/fd0

[pbhat at sidharth ~]$ ls -l /dev/ttySL0
lrwxrwxrwx  1 root root 10 Dec 30 14:26 /dev/ttySL0 -> /dev/pts/1
[pbhat at sidharth ~]$ ls -l /dev/pts/1
crw-rw----  1 root uucp 136, 1 Dec 30 15:45 /dev/pts/1

why not on modem? Is it safe to add normal users to 'uucp' group? or  
change modem group to a new group like 'dialout' and make users its  
members ?

I can 'sudo wvdial' successfully.


Parameshwara Bhat

Using Opera's revolutionary e-mail client:

More information about the fedora-list mailing list