[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Root mail account is dying



On Thu, 2005-06-02 at 21:32 -0400, A. Rick Anderson wrote:
> Paul Howarth wrote:
> > A. Rick Anderson wrote:
> > 
> >> Whenever I attempt to access mail from root, it pauses, then dies with 
> >> the following error message.
> ..
> >> fseek: Invalid argument
> >> panic: temporary file seek
> >> Aborted
> >> You have mail in /var/spool/mail/root
> > 
> > Perhaps /var/spool/mail/root lives on one of the bad disk blocks that 
> > SMART is complaining about?
> > 
> > Can you copy /var/spool/mail/root to another file and then open it with 
> > "Mail -f filename"?
> 
> Tried moving it to /root/mail and then opened it with the -f command.  I 
> got the exact same error.  However, since I had "moved" the mail file, 
> that effectively meant that the original file under /var/spool/mail was 
> now gone.
> 
> Running a simple mail gave me the expected "no mail" message, but exited 
> gracefully.  I am assuming the mail file was corrupted somehow.

Moving the file, if it was on the same partition, will result only in
directory entries being changed and not actually putting the data on
different disk blocks. If you still have the file, try copying it to
another file and trying again with "Mail -f filename". If that doesn't
work, the file probably is corrupt but you could try using formail to
"fix" it:

$ formail -ds < mailfile >> newmailfile

Paul.
-- 
Paul Howarth <paul city-fan org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]