[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Access to Sony Mavica CD-1000 digital camera no longer works FC3

On Mon, 2005-06-06 at 16:58 -0500, Jeff Vian wrote:
> On Mon, 2005-06-06 at 05:35 -0400, Marcus O. White wrote:
> > G'day All,
> > 
> > Finally upgraded remaining RHL 9.0 workstation to FC3. Now when I
> > attempt to access my Sony Mavica CD-1000 digital camera via USB it no
> > longer works. Whereas it worked under RHL 9.0. The system recognizes the
> > camera, as can seen from the following:
> > 
> > Jun  6 05:21:22 tbird kernel: usb 4-1: new full speed USB device using
> > uhci_hcd and address 3
> > Jun  6 05:21:24 tbird kernel: SCSI subsystem initialized
> > Jun  6 05:21:24 tbird kernel: Initializing USB Mass Storage driver...
> > Jun  6 05:21:24 tbird kernel: scsi0 : SCSI emulation for USB Mass
> > Storage devices
> > Jun  6 05:21:24 tbird kernel: usbcore: registered new driver usb-storage
> > Jun  6 05:21:24 tbird kernel: USB Mass Storage support registered.
> > Jun  6 05:21:29 tbird kernel:   Vendor: SONY      Model: DSC   DDX-G2000
> > Rev: 1.17
> > Jun  6 05:21:29 tbird kernel:   Type:   CD-ROM
> > ANSI SCSI revision: 02
> > Jun  6 05:21:29 tbird scsi.agent[9551]: cdrom
> > at /devices/pci0000:00/0000:00:10.2/usb4/4-1/4-1:1.0/host0/target0:0:0/0:0:0:0
> > Jun  6 05:21:30 tbird kernel: sr0: scsi3-mmc drive: 8x/8x writer
> > xa/form2 cdda pop-up
> sr0 is the driver
> > Jun  6 05:21:30 tbird fstab-sync[9614]: added mount
> > point /media/cdrecorder2 for /dev/scd0
> > Jun  6 05:21:30 tbird kernel: cdrom: This disc doesn't have any tracks I
> > recognize!
> > 
> Normal message for a usb attached cdrom with no disk in the drive.  It
> sees the drive but can't access the disk.
> Everything up to this point seems normal
> > When I attempt to mount it I see the following messages:
> > [root tbird ~]# mount -t udf /dev/sr0 /media/cdrecorder2
> You are trying to mount /dev/sr0 (the driver).  In the message about the
> mount point above it says the device is /dev/scd0. Thus it cannot be
> mounted with your command.  
> Since the fstab entry has been made, if you have need to manually mount
> it the command (as root) would be "mount /media/cdrecorder2". The rest
> of the data is taken from the fstab entry.  Media device by default will
> automount when a disk is available.  
> Did you even look at /media/cdrecorder2 to see if the content was
> already mounted?  Mine shows an icon on the desktop when I attach a
> media device (cdrom, camera, flash disk, etc.) and it auto-mounts.
> Also, you need to have a disk in the drive with a recognized filesystem
> to do the mount. Verify that is the case.
> A friend had a Sony camera that used a cdrom for the pictures.  The
> pictures were not actually in a filesystem until he told the camera to
> close the session and thus could not be read directly on another cdrom
> drive.  I never tried to connect it to my linux machine so I don't know
> if it would have been mountable while in the camera or not.
I tried the /dev/scd0 and /dev/sr0 (after manually creating it). Yes, I
checked to see if it had already mounted. This camera uses a 3" CD to
store the photos. I've heard that some users had to "finalize" the CD,
but that defeats the purpose of accessing it from the camera.

I last used this very same camera and CD a few days ago prior to
upgrading to FC3... Maybe I need to downgrade it or at least load the
last kernel rpm...

Any other ideas?

Marcus O. White <1lnxraider comcast net>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]