[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Sessions / cookies not working?



My organization just upgraded to a more powerful web server for our CMS site. We had to set up the server from scratch, installing PHP Version 4.3.11 and all the nuts and bolts for the server.

Our web site runs fine, but I notice now the php sessions are not showing up at all in the URLs.

The session files are there in the /tmp folder, but for some reason they are not using the session filenames I specified in the CMS config file nor in the php.ini.

Here is my session configs in php.ini:

Session Support  enabled
Registered save handlers  files user
Directive Local Value Master Value
session.auto_start Off Off
session.bug_compat_42 Off Off
session.bug_compat_warn On On
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure Off Off
session.entropy_file no value no value
session.entropy_length 0 0
session.gc_divisor 1000 1000
session.gc_maxlifetime 1440 1440
session.gc_probability 1 1
session.name PHPSESSID PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path /tmp /tmp
session.serialize_handler php php
session.use_cookies On On
session.use_only_cookies Off Off
session.use_trans_sid Off Off


And here is my CMS config file:

define('SESSION_NAME','SINAPSE10B_');
define('LOG_DIR','/tmp');


We are running FC3 with Apache 2.0 with PHP 4.3.11 and PostgreSQL 7.4.7. Any help would be greatly appreciated. Thanks.
_________________
Kurt




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]