[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems making commi



Andy Green wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Mark Sargent wrote:
| Hi All,
|
| ok, something just not right here,

The /usr/local qt tree has not come from Fedora, it's the tree you
abortively tried to compile from source.

yes, I folowed the install tips,

1.  Unpack the archive if you have not done so already:

       cd /usr/local
       gunzip qt-x11-free-3.3.4.tar.gz # uncompress the archive
       tar xvf qt-x11-free-3.3.4.tar   # unpack it

   This creates the directory /usr/local/qt-x11-free-3.3.4 containing the
   files from the main archive.

   Rename qt-x11-free-3.3.4 to qt (or make a symlink):

       mv qt-x11-free-3.3.4 qt

   The rest of this file assumes that Qt is installed in /usr/local/qt.

  Unless you got to the end of
that and are running qt libs compiled from that, you need to forget
about it.

well, I ran ./configure from within /usr/local/qt and then it states at the bottom of that, to run /usr/bin/gmake. This is where I think I messed up. I ran /usr/bin/gmake, but, I should have just ran make, followed my make install..that line at the bottom after the initial ./configure was/is misleading...currently running make now from within /usr/local/qt...this should correct it..sorry for the pain...lol..



You need the kde-libs-devel package to compile the thing, it includes various helper apps.

ok, I thought the qt-devel. suggested by Paul Howarth, would give the same result...


  To get the correct path to everything, you need to
~ install the kde-libs-devel and do IN THIS ORDER

export QTDIR=/usr/lib/qt-3.3
./configure
make && su -c 'make install'

- -Andy



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]