[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

KDE blacklist of Fedora Core's gcc 4



Hello, Everyone
First of all, a personal message to Arjan: I CC'd this to you because
of your involvement with a thread about this issue on the fedora-test
list.  If I am out of order in CC'ing you, I do apologize.


This issue was originally discussed on the fedora-test list, shortly
before FC4 was released.  Since FC4 has been released, and the problem
persists, I assumed the fedora-user list would be the place to take
this. If you all say so, I will restart this thread on any list you
tell me to.

When attempting to compile KDE from SVN TRUNK on Fedora Core
4 (Fresh installation, not an upgrade.  I waited for the official
release as well.  In addition, I installed EVERY package) I get the
following error:

> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ANSI C... none needed
> checking dependency style of gcc... gcc3
> checking how to run the C preprocessor... gcc -E
> checking for g++... g++
> checking whether we are using the GNU C++ compiler... yes
> checking whether g++ accepts -g... yes
> checking dependency style of g++... gcc3
> checking whether gcc is blacklisted... yes
> configure: error:
> 
> This particular compiler version is blacklisted because it
> is known to miscompile KDE. Please use a newer version, or
> if that is not yet available, choose an older version.
> 
> Please do not report a bug or bother us reporting this
> configure error. We know about it, and we introduced
> it by intention to avoid untraceable bugs or crashes in KDE.

On the fedora-test list thread that I referred to earlier, Arjan van de
Ven <arjanv redhat com> said the following:
> the bug they mention is fixed in our gcc 4.

that quote came in the following context:
> > Hello, Everyone
> > Since I frequent the kde-devel and kde-user lists, in addition to
> > compiling, on a very regular basis, KDE from CVS (now SVN) HEAD on
> > Fedora Core 3, I do know a LITTLE about this issue.
> > Below is a link to the CVS commit where KDE's blacklisting of GCC4
> > seems to have started:
> > http://lists.kde.org/?l=kde-cvs&m=111451142117674&w=2

the bug they mention is fixed in our gcc 4.

I am the one responsible for the link to KDE's cvs log.

If KDE is at fault in not removing the blacklist against the version of
gcc that Fedora happens to use, I would be glad to forward any
information to them that might be persuasive in getting this fixed.  Of
course, you could do the same thing, but I have a lot more time on my
hands than you do :)

Thank you,
Steven P. Ulrick


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]