[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dual Boot Problem



Jessie Veltman wrote:

On 6/14/05, Jim Cornette <fc-cornette insight rr com> wrote:


Jessica L. Veltman wrote:



Try booting with a Windows XP CD and running 'fixmbr' in the recovery
console.  That removes any instances of GRUB from the MBR.  I had this
same problem, and after I did that and re-installed Fedora, GRUB
re-installed itself to the MBR, and it worked fine.

Let me know if you do that and it doesn't work, or if it does for that




matter!




--
PHP rocks!
"Knowledge is Power.  Power Corrupts.  Go to school, become evil"

Disclaimer: Any disclaimer attached to this message may be ignored.
However, I must say that the ENTIRE contents of this message are
subject to other's criticism, corrections, and speculations.

This message is Certified Virus Free




I tried doing all of that, but the results were the same. After the
installation restarted, my computer booted straight into Windows again.





Grub comes up using a hidden menu feature by default. The timing is set
to 3 seconds or something low. When XP is set as the default boot loader
and you have a quck booting computer with a CRT monitor, you do not see
the grub screen at all. Try hitting a space bar during your computer
booting. This should display the hidden menu.

It sounds like grub should have installed correctly. I do remember an
instance during development where I could not get a bootloader to
install or work. This was on a computer with Phoenix BIOS. I only tried
the install once on this computer and set it aside. This might be some
grub boot loader problem with the version of grub on FC4. I believe
there are bug reports filed on this issue. I am not sure the bugs were
worked out or are still open. Try searching Bugzilla for grub problems
related to not installing as intended.

Jim

--
The best things in life go on sale sooner or later.



I actually have fedora set as the default, and I have an LCD monitor.
I tried it anyway and it just came up with a windows boot choice
screen, not grub. There is nothing in Bugzilla that I could fine but I
will put it in as a bug. It would be really nice to get this solved :)
Thanks for the help




I see the bug that you entered. Bug # 160396

I'll check the computer that failed during a test with FC4T2 to see if it still fails to install grub, even boting from the rescue disc, chrooting to /mnt/sysimage, then running grub-install /dev/hda and rebooting.

Not being able to boot the install afterwards does lead to shelving the installation attempt.

I suppose that you tried to boot into rescue mode by typing "linux rescue" using disc 1. Then when the installation is detected and mounted as /mnt/sysimage you typed "chroot /mnt/sysimage". After your system chrooted the installation, you could run "grub-install /dev/hda" and then reboot.

If that fails, you can get back into the rescue environment, chroot /mnt/sysimage, then mount the disc from fc3 which contains the older version of grub, insert the CD, then mount the CD and change to the directory which contains the FC3 version of grub. Install the older package with rpm using the below:
rpm -Uvh grub*.rpm --oldpackage
After the older version of grub is installed, try the "grub-install /dev/hda" again and reboot. If the system does not come up with the older grub version, I have no idea as how to correct the bootloader problem.


Good Luck!

Jim

Jim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]