[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dual Boot Problem




I just tried "grub-install /dev/hda", but no luck. It gave me the
error "/dev/hdb1 does not have any corresponding BIOS drive". The only
thing I can think of is that this is somehow related to the fact that
I have a SATA drive on my system. I'm a crazy geek who has 4 hard
drives running, 3 IDE and 1 SATA. Both Windows and Fedora are on IDE
drives though, so I'm not sure whats going on.



This sounds related to what Barry mentioned about the device.map
cat /boot/grub/device.map
puts out this information on my single disk laptop. What does the device.map file contain on your system.
cat /boot/grub/device.map
# this device map was generated by anaconda
(fd0) /dev/fd0
(hd0) /dev/hda


What does fdisk -l output?
fdisk -l
Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2111    16956576    7  HPFS/NTFS
/dev/hda2            2112        2124      104422+  83  Linux
/dev/hda3            2125        3399    10241437+  83  Linux
/dev/hda4            3400        4864    11767612+   5  Extended
/dev/hda5            3400        4674    10241406   83  Linux
/dev/hda6            4675        4805     1052226   82  Linux swap / Solaris
/dev/hda7            4806        4864      473886    b  W95 FAT32

I'm sure that with 3 IDE disks and the SATA, it should confuse anaconda a bit. Grub.conf would also give clues as to what failed to recognize the setup you have.

Jim

--
Wow, I'm being shot at from both sides.  That means I *must* be right.  :-)
            -- Larry Wall in <199710211959 MAA18990 wall org>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]