[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Problem with apache, php and mysql after FC4 upgrade: SegmentationFault ...



On Wed, 2005-06-15 at 12:26 -0700, bruce wrote:
> i take it that you'r eusing the vanilla php/mysql that came with FC4...

You betcha

> 
> what (if anything) did the mysql/php sites say regarding FC4?

Still checking/google-ing, but I've found nothing yet :(



> 
> i'd advise you to create a simple php test to simply connect to the db, and
> see if you get this to work.. shouldn't be more than 10-20 lines of code....

I just did that. Just a simple connect to the database and give me your
status kinda-thing. Strangely, from the command line (php ./test.php),
it works fine, no errors, etc. It's only when it's run with apache that
it seg-faults.



> 
> i also believe that php/mysql provides the ability to return an err status
> from a mysql_connect call... what's the error say?

I think you're referring to mysql_error()? Well, I can't even get that
far. See, that function only returns the error after a mysql
function/query is run, but my script seg-faults during the mysql_connect
call, so I never get to use mysql_error() :)

> 
> let us know..
> 
> -bruce
> 
> 
> -----Original Message-----
> From: fedora-list-bounces redhat com
> [mailto:fedora-list-bounces redhat com]On Behalf Of Mark Linford
> Sent: Wednesday, June 15, 2005 12:14 PM
> To: fedora-list redhat com
> Subject: Problem with apache, php and mysql after FC4 upgrade:
> SegmentationFault ...
> 
> 
> Hi, everyone:
> 
> I just finished my upgrade to FC4 last night, and so far, everything's
> running smoothly, except for an issue with mysql and php ...
> 
> I'm having problems with certain php scripts causing apache to
> seg-fault. After a little debugging, I narrowed it down to the php
> function mysql_connect. Whenever the script hits that line, the
> web-server child dies. However, there's no php error, either on screen
> or in my php.log file. Only this error shows up in error_log:
> 
> [Wed Jun 15 11:40:41 2005] [notice] child pid 1877 exit signal
> Segmentation fault (11)
> 
> What's odd is that mysqld seems to be working fine since the upgrade. I
> can connect from the command line using the same username, password and
> queries I use in my php script with no problems.
> 
> Any Ideas? Anyone else having this problem?
> 
> 
> 
> Mark
> 
> 
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]