[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Kickstart confusion



I am trying to run some post install commands with a kickstart installation, but some of them don't work;

%post
/sbin/chkconfig --levels 2345 isdn off -WORKS
/sbin/chkconfig --levels 2345 pcmcia off - WORKS
/sbin/chkconfig --levels 2345 ypbind off - WORKS
/sbin/chkconfig --levels 2345 ntpd on - WORKS
mkdir /mnt/install -WORKS
mount -t nfs 128.40.159.53:/export/ftp /mnt/install - WORKS
rpm -ivh /mnt/install/os/packages/apt* - WORKS
rpm -ivh /mnt/install/os/packages/webmin* - WORKS
rpm -ivh /mnt/install/os/kernel/kernel-2.6*- DOES NOT WORK
rpm -ivh /mnt/install/os/kernel/kernel-smp*- DOES NOT WORK
rpm -ivh /mnt/install/os/kernel/kernel-utils*- DOES NOT WORK
rpm --import /mnt/install/os/packages/RPM* - WORKS
rpm --import /usr/share/rhn/RPM-GPG-KEY - WORKS
cp -a --reply=yes /mnt/install/os/configs/* /mnt/sysimage/etc - DOES NOT WORK
ntpdate a.server.co.uk - WORKS
service autofs restart - WORKS
service ntpd restart - WORKS
apt-get -y update - WORKS
apt-get -y upgrade - WORKS


The kernel install I think I understand, but the copy command I don't. The syntax is correct, but I think it may be something to do with the chroot environment, the manual suggests running with %post --nochroot, but if I do this nothing works at all.

I assume I have done something really stupid which I just can't see. Can anyone tell me where I have gone wrong.

Thanks,

Neil.

--
Neil Marjoram
Systems Manager
Adastral Park Campus
University College London
Ross Building
Adastral Park
Martlesham Heath
Ipswich - Suffolk
IP5 3RE


Reclaim Your Inbox! http://www.mozilla.org/products/thunderbird


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]