[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC4 broken SB Audigy controls



I had a similar problem.  Ron, you need too look at the doc [1].

http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Sound+Blaster+Audigy+ES.&chip=emu10k2&module=emu10k1#opt

My problem was after I installed FC4 I did not have _any_ audio output. After investigating I found that my speakers were Digital.. I tried some headphones (Analog) and lo, they work. So, after finding the above doc it mentions running alsamixer. I arrow-ed to the right, found the "Audigy Analog/Digital Output Jack" item and hit "M" for unMute.. It works now. Hope this helps. If you can't get to the doc, I found an email from Alexander D. [2] which led me to the appropriate ALSA site for documentation. From there I selected details on emu10k1.

Peter

[1] http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Sound+Blaster+Audigy+ES.&chip=emu10k2&module=emu10k1#opt
[2] https://www.redhat.com/archives/fedora-list/2005-June/msg01206.html


Ron Hawkins wrote:

I have used the same SB Audigy card for 3 years and never had a problem with it until FC4.

Line-in and Microphone input does not put out any sound. KDE's kmix seems to break the
sound altogether and Gnome's mixer restores all but the line-in and Mic.


Here is my /etc/modprobe.conf:
- - -
alias eth0 3c59x
alias eth1 e100
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe
-r --ignore-remove snd-emu10k1
alias char-major-81 bttv
options bttv card=1 tuner=6
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias usb-controller2 uhci-hcd
alias ieee1394-controller ohci1394
- - -
Here is outout from lspci:
- - -
00:00.0 Host bridge: Intel Corporation 82850 850 (Tehama) Chipset Host Bridge (M CH) (rev 04)
00:01.0 PCI bridge: Intel Corporation 82850 850 (Tehama) Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 04)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 04)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
02:01.0 USB Controller: NEC Corporation USB (rev 41)
02:01.1 USB Controller: NEC Corporation USB (rev 41)
02:01.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
02:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Contr oller (rev 03)
02:0a.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
02:0b.0 Multimedia video controller: Brooktree Corporation Bt848 Video Capture ( rev 12)
02:0c.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
02:0c.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port
- - -
dmesg provides only these lines relating to sound card.
- - -
e100: eth1: e100_probe: addr 0xfeafc000, irq 11, MAC addr 00:03:47:D3:FA:EB
ACPI: PCI Interrupt 0000:02:0c.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
Installing spdif_bug patch: Audigy 1 or 2 [Unknown]
hw_random hardware driver 1.0.0 loaded
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Linux video capture interface: v1.00
bttv: driver version 0.9.15 loaded
- - -


Let me know what other information might be needed.  I am at a loss here.

TIA,

Ron



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]