[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC4: ipw2200 & wpa_supplicant



Hi List,

i'm own a Dell Inspiron 9300 with Intel Corporation PRO/Wireless 2915ABG
MiniPCI Adapter (rev 05) and Netgear WGR614 AP.

FC4 contains by default the kernel modules ipw2200, ieee80211,
ieee80211_wep, ieee80211, ieee80211_crypt, ieee80211_crypt_wep,
ieee80211_tkip and ieee80211_crypt_ccmp. FC4 kernel .config says that
WPA ist enabled für the ipw2200 modules and build as modules.

After i've installed the ipw2200 firmware in /lib/firmware i can
successfully connect to wlan AP unencrypted and with wep, but i want to
go with wpa-psk. So i've read the net about it and installed
wpa_supplicant, but i can't get it to connect via wpa-psk:

I've some messages from wpa_supplicant in debug mode:

----------------------------------------------------------------------
(...)
Selecting BSS from priority group 0
0: 00:0f:b5:a1:9f:14 ssid='WIZARDS-LAIR' wpa_ie_len=0 rsn_ie_len=0
   skip - no WPA/RSN IE
No suitable AP found.
(...)
Starting AP scan (specific SSID)
Scan SSID - hexdump_ascii(len=12):
     57 49 5a 41 52 44 53 2d 4c 41 49 52               WIZARDS-LAIR
ioctl[SIOCSIWSCAN{,EXT}]: Operation not supported
Failed to initiate AP scan.
(...)
wpa_driver_ipw_set_wpa: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_drop_unencrypted: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
No keys have been configured - skip key clearing
(...)
----------------------------------------------------------------------

All i've found can't helps me. What is the next step i can try?
Recompile the Fedora Kernel an build the ipw2200 into kernel and not as
modules or install the actual ipw2200 1.0.4 modules and overwrite the
kernel modules and how i do this the right way?

I'm very happy for any help about wpa-psk in FC4 with ipw2200.

BTW: On the search i've found some infos about "Gnome NetworkManager"
and tried it with wep, great tool, works! Unfortunately it isn't ready
for wpa at this time.

Thank you very much for helping.

Greetz
Dirk



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]