[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Stuck on run-level 3 :-(



----- Original Message ----- 
From: Paul Howarth
Newsgroups: gmane.linux.redhat.fedora.general
Sent: Friday, June 17, 2005 4:25 PM
Subject: Re: Stuck on run-level 3 :-(


Andoni wrote:
> I have found that the card is a JetWay 94V but when I set the value to
> JetWay I still have no luck!
> I am still getting the respawning error:
> INIT: Id "x" respawning too fast: disabled for 5 minutes
> when I do an init 5.
> When I run your /sbin/lspci it tells me the graphics card is:
> VGA compatible controller: Intel Corp. 82740 (i740) AGP Graphics
Accelerator
> (rev 21).
> even with the controller in system-config-display set to JetWay.
>
> The error I am getting seems to relate to a line at the end of my inittab
> file which reads:
>
> # Run xdm in runlevel 5
> x:5:respawn:/etc/X11/prefdm -nodaemon
>
> could this be causing a problem?

This is a side-effect of the underlying problem, which is that your X
configuration is broken. My previous email described how to get
diagnostics for that problem.

The error message you are seeing about respawning is because in runlevel
5 the init process is trying to start X but it keeps failing due to the
aforementioned configuration issue, hence init keeps trying to restart
it. Eventually it gives up and shows you that error message.

So boot to runlevel 3 as mentioned before and you can get some
information about the actual problem is using "startx".

Paul.

-- 


I got the diagnostic information you spoke of and it was in two parts:
$ /sbin/lspci
revealed that my card is an
> VGA compatible controller: Intel Corp. 82740 (i740) AGP Graphics
Accelerator
> (rev 21).
and the startx command does not work.

When I tried changing back to intel Generic Card I got the same error as
before.

Another point: When I do the: init 5 command I get (amongst other things)
starting automount: No mountpoints defined.

Could this have some effect.

Also, In my grub.conf on the kernel line I was advised to put a "nofb"
parameter to solve an earlier problem. Could this be getting in the way now?
It was a display problem that time also but the screen was black then.

My fstab looks like:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/hdb                /media/cdrom            auto
pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed 0
0
/dev/fd0                /media/floppy           auto
pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0


Thanks,
Andoni.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]