[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Stuck on run-level 3 :-(



----- Original Message ----- 
From: Paul Howarth
Newsgroups: gmane.linux.redhat.fedora.general
Sent: Friday, June 17, 2005 6:27 PM
Subject: Re: Stuck on run-level 3 :-(


Andoni wrote:
> Same problem. /usr/X11R6/bin needs to be in your PATH.
>
> Try:
> $ PATH="$PATH:/usr/X11R6/bin"
> $ startx &> x.output
>
> Also, what is the output of:
> $ echo $PATH
>
> Paul.
>
>
> ================
> Adding it to path worked and then it tried really hard to startx but then
it
> crashed out with an error that made me think it may not be using the
correct
> video driver so I set it back to the Intel Generic but I got the same
error
> message. This one:
>
> [root localhost ~]# startx
>
> X Window System Version 6.8.2
> Release Date: 9 February 2005
> X Protocol Version 11, Revision 0, Release 6.8.2
> Build Operating System: Linux 2.6.9-1.906_ELsmp i686 [ELF]
> Current Operating System: Linux localhost.localdomain 2.6.9-1.667 #1 Tue
Nov
> 2 14:41:25 EST 2004 i686
> Build Date: 24 March 2005
> Build Host: tweety.build.redhat.com
>
>         Before reporting problems, check http://wiki.X.Org
>         to make sure that you have the latest version.
> Module Loader present
>
> OS Kernel: Linux version 2.6.9-1.667 (bhcompile tweety build redhat com)
> (gcc version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 Tue Nov 2 14:41:25
EST
> 2004
> Markers: (--) probed, (**) from config file, (==) default setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 17 17:21:50 2005
> (==) Using config file: "/etc/X11/xorg.conf"
> Symbol xf86CreateI2CBusRec from module
> /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!
> Symbol xf86I2CBusInit from module
/usr/X11R6/lib/modules/drivers/i740_drv.o
> is unresolved!

I believe that symbol should be resolved from
/usr/X11R6/lib/modules/libi2c.a

Does that file exist?

> Agent pid 2780
>
> waiting for X server to shut down

Could you post your /etc/X11/xorg.conf?

Are there any interesting-looking error messages in /var/log/Xorg.0.log?

Paul.

-- 

Contents of file xorg.conf is below.
There does not seem to be anything of interest in the log.
The driver file does exist, is this something I can point the xorg.conf at?

I am afraid I have to leave this problem until Monday. Thank you very much
for your help to date. I will read anything you might post back on Monday
morning.

Andoni.



[root localhost ~]# cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of
the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection

Section "ServerFlags"
        Option      "AllowMouseOpenFail" "yes"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Gateway Vivitron 15"
        HorizSync    31.0 - 64.0
        VertRefresh  50.0 - 120.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "i740"
        VendorName  "Videocard vendor"
        BoardName   "Intel 740 (generic)"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     8
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
                Modes    "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode         0666
EndSection

[root localhost ~]#



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]