[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: modprobe ndiswrapper --> Invalid module format



Am So, den 19.06.2005 schrieb Gezim Hoxha um 13:27:

> I'm trying to install ndiswrappers in FC4. I followed the installation
> manual in their site, but specifically here is what I did.
> 
> First I extracted kernel-devel-2.6.11-1.1369_FC4.i686.rpm.
> Then I did "rpm -Uvh kernel-devel-2.6.11-1.1369_FC4.i686.rpm".

*single CPU kernel-devel package*

> It said that it needs hardlink. I extracted hardlink (from cd 1 I
> think). Then I did "rpm -Uvh hardlink-1.0-1.13.i386.rpm". This
> installed, then the kernel installed. Yay!
> Next I attemted to install gcc using same method as last two packages
> but this didn't work too well (had too many dependencies), so I then
> decided to "system-config-packages" the development-tools installed
> fine. Thinking that I didn't have openssl-devel I tried to uncompress it
> from a cd (#1 I think) and then tried to install it but told me that it
> already is installed. 
> Then I downloaded ndiswrappers-1.2 from their site.
> Did:
> then I linked 
> ln
> -s /usr/src/kernels/2.6.11-1.1369_FC4-i686/ /lib/modules/2.6.11-1.1369_FC4smp/build 

You linked the kernel includes for the single CPU / non-smp kernel into
the SMP kernel modules directory. That can't lead to something useful!

> [root WarpPower ndiswrapper-1.2]# modprobe ndiswrapper
> FATAL: Error inserting ndiswrapper
> (/lib/modules/2.6.11-1.1369_FC4smp/misc/ndiswrapper.ko): Invalid module

*smp kernel!*

> -Gezim

Alexander


-- 
Alexander Dalloz | Enger, Germany | GPG http://pgp.mit.edu 0xB366A773
legal statement: http://www.uni-x.org/legal.html
Fedora Core 2 GNU/Linux on Athlon with kernel 2.6.11-1.27_FC2smp 
Serendipity 15:43:21 up 27 days, 14:21, load average: 0.10, 0.15, 0.17 

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]