[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum cannot resolve missing dependencies



Hi all

When I type yum update, it starts resolving dependencies, and after a time it 
stops and spits out a whole list of errors (see below)

<yum.con>
[French-Fedora-Mirror]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://fr2.rpmfind.net/linux/fedora/core/updates/3/$basearch/
name=Fedora extras - $releasever - $basearch
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/3/$basearch
gpgcheck=1
gpgkey=http://download.fedora.redhat.com/pub/fedora/linux/extras/RPM-GPG-KEY-Fedora-Extras

So isn't yum supposed to fix dependencies on its own?

With kind regards


Andy



Error: Missing Dependency: cpp = 3.4.3-22.fc3 is needed by package gcc
Error: Missing Dependency: libedata-book.so.1 is needed by package gaim
Error: Missing Dependency: libebook.so.8 is needed by package gaim
Error: Missing Dependency: libedataserver.so.3 is needed by package gaim
Error: Missing Dependency: libcrypto.so.5 is needed by package gftp
Error: Missing Dependency: libcrypto.so.5 is needed by package subversion
Error: Missing Dependency: libssl.so.5 is needed by package kdelibs
Error: Missing Dependency: libcrypto.so.5 is needed by package python
Error: Missing Dependency: libssl.so.5 is needed by package stunnel
Error: Missing Dependency: libcrypto.so.5 is needed by package fetchmail
Error: Missing Dependency: libssl.so.5 is needed by package kdebase
Error: Missing Dependency: libcrypto.so.5 is needed by package kdebase
Error: Missing Dependency: libcrypto.so.5 is needed by package cyrus-sasl-md5
Error: Missing Dependency: libcrypto.so.5 is needed by package wget
Error: Missing Dependency: libcrypto.so.5 is needed by package ethereal-gnome
Error: Missing Dependency: libcrypto.so.5 is needed by package kdeutils
Error: Missing Dependency: libcrypto.so.5 is needed by package lftp
Error: Missing Dependency: libcrypto.so.5 is needed by package bind-utils
Error: Missing Dependency: libcrypto.so.5 is needed by package rpm-devel
Error: Missing Dependency: libcrypto.so.5 is needed by package net-snmp
Error: Missing Dependency: libcrypto.so.5 is needed by package 
cyrus-sasl-devel
Error: Missing Dependency: libcrypto.so.5 is needed by package pam_ccreds
Error: Missing Dependency: libcrypto.so.5 is needed by package 
perl-Crypt-SSLeay
Error: Missing Dependency: libssl.so.5 is needed by package libgnomeprint22
Error: Missing Dependency: libcrypto.so.5 is needed by package mutt
Error: Missing Dependency: libssl.so.5 is needed by package fetchmail
Error: Missing Dependency: libssl.so.5 is needed by package mutt
Error: Missing Dependency: libssl.so.5 is needed by package gftp
Error: Missing Dependency: libcrypto.so.5 is needed by package libwvstreams
Error: Missing Dependency: libssl.so.5 is needed by package kdenetwork
Error: Missing Dependency: libcrypto.so.5 is needed by package elinks
Error: Missing Dependency: libcrypto.so.5 is needed by package kdesdk
Error: Missing Dependency: libcrypto.so.5 is needed by package libgnomecups
Error: Missing Dependency: libssl.so.5 is needed by package xchat
Error: Missing Dependency: libcrypto.so.5 is needed by package nmap
Error: Missing Dependency: libssl.so.5 is needed by package libgnomecups
Error: Missing Dependency: libssl.so.5 is needed by package iiimf-libs
Error: Missing Dependency: libcrypto.so.5 is needed by package rpm-build
Error: Missing Dependency: libssl.so.5 is needed by package subversion
Error: Missing Dependency: libcrypto.so.5 is needed by package kdelibs
Error: Missing Dependency: libssl.so.5 is needed by package gwenhywfar
Error: Missing Dependency: libssl.so.5 is needed by package slrn
Error: Missing Dependency: libssl.so.5 is needed by package neon
Error: Missing Dependency: libcrypto.so.5 is needed by package 
openldap-clients
Error: Missing Dependency: libcrypto.so.5 is needed by package cups-libs
Error: Missing Dependency: libssl.so.5 is needed by package vorbis-tools
Error: Missing Dependency: libcrypto.so.5 is needed by package neon
Error: Missing Dependency: libcrypto.so.5 is needed by package bind-libs
Error: Missing Dependency: libssl.so.5 is needed by package cups
Error: Missing Dependency: libssl.so.5 is needed by package lftp
Error: Missing Dependency: libcrypto.so.5 is needed by package ckermit
Error: Missing Dependency: libssl.so.5 is needed by package net-snmp
Error: Missing Dependency: libssl.so.5 is needed by package rpm
Error: Missing Dependency: libcrypto.so.5 is needed by package sendmail
Error: Missing Dependency: libssl.so.5 is needed by package perl-Crypt-SSLeay
Error: Missing Dependency: libssl.so.5 is needed by package pyOpenSSL
Error: Missing Dependency: libcrypto.so.5 is needed by package slrn
Error: Missing Dependency: libssl.so.5 is needed by package elinks
Error: Missing Dependency: libcrypto.so.5 is needed by package iiimf-libs
Error: Missing Dependency: libssl.so.5 is needed by package nmap
Error: Missing Dependency: libcrypto.so.5 is needed by package ethereal
Error: Missing Dependency: libcrypto.so.5 is needed by package openldap
Error: Missing Dependency: openssl = 0.9.7f-7 is needed by package 
openssl-devel
Error: Missing Dependency: libcrypto.so.5 is needed by package openssh
Error: Missing Dependency: libcrypto.so.5 is needed by package 
desktop-printing
Error: Missing Dependency: libssl.so.5 is needed by package python
Error: Missing Dependency: libcrypto.so.5 is needed by package vorbis-tools
Error: Missing Dependency: libssl.so.5 is needed by package desktop-printing
Error: Missing Dependency: libssl.so.5 is needed by package gnome-vfs2
Error: Missing Dependency: libcrypto.so.5 is needed by package gwenhywfar
Error: Missing Dependency: libssl.so.5 is needed by package rpm-build
Error: Missing Dependency: libssl.so.5 is needed by package libwvstreams
Error: Missing Dependency: libcrypto.so.5 is needed by package python-ldap
Error: Missing Dependency: libcrypto.so.5 is needed by package bind
Error: Missing Dependency: libcrypto.so.5 is needed by package ipsec-tools
Error: Missing Dependency: libcrypto.so.5 is needed by package ntp
Error: Missing Dependency: libssl.so.5 is needed by package openldap-clients
Error: Missing Dependency: libssl.so.5 is needed by package cups-libs
Error: Missing Dependency: libssl.so.5 is needed by package wget
Error: Missing Dependency: libcrypto.so.5 is needed by package openssh-clients
Error: Missing Dependency: libssl.so.5 is needed by package ckermit
Error: Missing Dependency: libssl.so.5 is needed by package openldap
Error: Missing Dependency: libcrypto.so.5 is needed by package cadaver
Error: Missing Dependency: libcrypto.so.5 is needed by package cups
Error: Missing Dependency: libssl.so.5 is needed by package sendmail
Error: Missing Dependency: libcrypto.so.5 is needed by package xchat
Error: Missing Dependency: libcrypto.so.5 is needed by package pyOpenSSL
Error: Missing Dependency: libcrypto.so.5 is needed by package lynx
Error: Missing Dependency: libssl.so.5 is needed by package samba-common
Error: Missing Dependency: libcrypto.so.5 is needed by package net-snmp-libs
Error: Missing Dependency: libssl.so.5 is needed by package lynx
Error: Missing Dependency: libssl.so.5 is needed by package ethereal
Error: Missing Dependency: libcrypto.so.5 is needed by package curl
Error: Missing Dependency: libssl.so.5 is needed by package ethereal-gnome
Error: Missing Dependency: libcrypto.so.5 is needed by package cyrus-sasl
Error: Missing Dependency: libssl.so.5 is needed by package curl
Error: Missing Dependency: libcrypto.so.5 is needed by package libgnomeprint22
Error: Missing Dependency: libcrypto.so.5 is needed by package rpm
Error: Missing Dependency: libssl.so.5 is needed by package rpm-devel
Error: Missing Dependency: libssl.so.5 is needed by package python-ldap
Error: Missing Dependency: libssl.so.5 is needed by package cyrus-sasl-devel
Error: Missing Dependency: libcrypto.so.5 is needed by package gnome-vfs2
Error: Missing Dependency: libcrypto.so.5 is needed by package samba-common
Error: Missing Dependency: libcrypto.so.5 is needed by package stunnel
Error: Missing Dependency: libcrypto.so.5 is needed by package dhcpv6_client
Error: Missing Dependency: libcrypto.so.5 is needed by package openssh-server
Error: Missing Dependency: libcrypto.so.5 is needed by package hpoj
Error: Missing Dependency: libcrypto.so.5 is needed by package kdenetwork
Error: Missing Dependency: libssl.so.5 is needed by package cadaver
Error: Missing Dependency: libssl.so.5 is needed by package kdesdk

-- 
Registered Linux User Number 379093
-- --BEGIN GEEK CODE BLOCK-----
Version: 3.1
GAT/O/>E$ d-(---)>+ s:(+)>: a--(-)>? C++++$(+++) UL++++>++++$ P-(+)>++
L+++>++++$ E---(-)@ W+++>+++$ !N@ o? !K? W--(---) !O !M- V-- PS++(+++)
PE--(-) Y+ PGP++(+++) t+(++) 5-- X++ R*(+)@ !tv b-() DI(+) D+(+++) G(+)
e>++++$@ h++(*) r-->++ y--()>++++
-- ---END GEEK CODE BLOCK------
--
Check out these few php utilities that I released
 under the GPL2 and that are meant for use with a 
 php cli binary:
 
 http://www.vlaamse-kern.com/sas/
--

--

Attachment: pgpKiBQHnBuXN.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]