[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fresh FC4 install issues



On Wed, 2005-06-15 at 21:29 -0400, Jim Cornette wrote:
> AdabalaP schneider com wrote:
> > > I tried to performed a graphical install but got a "white screen",
> > > So switched to test based install, Installation went fine. Now i
> > > get the same "white screen" when i rebooted. Has any one seen this
> > > issue ?
> > >
> > > Details: Model - Compaq Presario, Video Card - Cyber Blade
> >
> 
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160580
> 
> This person has.
> 
> What might be helpful is to try to replace the file described in
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=157556
> regarding replacing /usr/X11R6/lib/modules/libvgahw.a
> with a version from extracting it from the latest FC3 version of xorg-x11.
> 
> Good luck!
> What this will provide is confirmation that this file is wreaking havoc 
> on a slew of different video cards. If it works, you will have more than 
> a white screen for your GUI.
> Including binary hacks with released binaries are not sent out with the 
> binary rpms. sometimes the hack is desirable compared to the 
> alternatives though.
> Rename the FC4 version before you do this replacement. You might need to 
> restart the computer, change runlevel or restart the x server in some 
> other way for the change to take effect.
> 
> I like to use mc (midnight commander) to dive into rpms to extract files 
> from it. There are probably other utilities to extract the file, but 
> just a suggested program.
> 
> Jim

The white screen seems to be a problem with Trident CyberBlade
videocards, which I have, so I couldn't get the GUI install to work at
all. I installed FC4 alongside FC3, on a separate partition, using the
text install. Then I could try the trick of substituting files, without
risking loss of a working FC3. 
The bugzilla report mentioned above suggests two changes:
	/usr/X11R6/lib/modules/libvgahw.a
and	/usr/X11R6/lib/modules/drivers/mga_drv.o
I did this by mounting the FC4 partition in FC3 so I could just copy the
files across from FC3 to FC4 directories. In short, it worked and FC4
looks very nice.

I'll put a report into bugzilla soon but I want to try just changing one
file at a time.
-- 
James Bridge <james xmas demon co uk>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]