[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC4 & yum : kudos and a small oddity



The FC4 install media arrived yesterday, and I began with an upgrade (FC2
> FC4) on my most expendable machine, partly just to try out the upgrade
process. After the install I immediately did yum upgrade.

Most things went very well, and my first impression is extremely
favorable: kudos and much thanks to the developers, both for FC4 in
general, and for the new version of yum!

I did find an odd nit to pick which may interest some, or be slightly more
serious than it is (hardly at all) with this first machine -- one that
seems, at least to my half-informed grasp of such things, likely to affect
more cases than this minor one, and looks like it might arise down the
road with upgrades even of fresh installs in certain cases.

My machine was running Pan 0.14.2, and Pine 4.63 from an rpm with fc2 in
its name; I would also have gone for that Pan release with a fresh
install.

Yum switched Pan to 0.14.2.91, and rpm -Uvh on a generic Fedora rpm from
UW would not take, saying the installed version was later.

I expect I can solve the Pine oddity by running "rpm -e pine" and then
installing the generic; that will be easy, since Pine was barely
configured yet -- on this particular machine.

Doing the same with Pan will be a bit of a hassle, especially on other
machines, since all the data for a fully configured instance of Pan (at
least as I run it) is bigger than a CD will hold.

I don't know what the answer is; I'd like to hear if there is one -- some
sort of an override capability? Preferably one that doesn't have to be
attended to every time the user runs yum?

The nit itself reminds me of what synaptic did, when I tried that for a
while. It hasn't been obvious from the subject lines of the threads I've
been following in this venue; I apologize if it's already been discussed
here more than I realize.

-- 
Beartooth Neo-Redneck, Linux Evangelist
FC 1-4, YDL 4; Pine 4.63, Pan 0.14.2; Privoxy 3.0.3; 
Dillo 0.8.5, Opera 8.01, Firefox 1.0.4, Epiphany 1.0.8
Remember that I have little idea what I am talking about.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]