[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Missing MIDI in Alsa



I'm having trouble with MIDI & FC4 & Mac MINI & Alsa.
It worked a couple days ago, but now it's broken. As far as
I know, all I did to break it was reboot, without a USB sound
device which I also had plugged in previously. So let me describe:

I have a Mac mini, which I loaded FC4 onto. I wish to use raw MIDI
with a program I've written. I plug in a Edirol UM-1X USB MIDI
interface, and the following shows up in /var/log/messages:

Jun 27 08:43:16 mini kernel: usb 4-1: new full speed USB device using
ohci_hcd and address 3
Jun 27 08:43:16 mini kernel: usb-midi: Found MIDISTREAMING on dev
0582:0052, iface 0
Jun 27 08:43:16 mini kernel: usb-midi: Found MIDIStreaming device
corresponding to Release 1.00 of spec.
Jun 27 08:43:16 mini kernel: usb-midi: Found IN Jack 0x10 EMBEDDED
Jun 27 08:43:16 mini kernel: usb-midi: Found IN Jack 0x20 EXTERNAL
Jun 27 08:43:16 mini kernel: usb-midi: Found OUT Jack 0x30 EMBEDDED, 1 pins
Jun 27 08:43:16 mini kernel: usb-midi: Found OUT Jack 0x40 EXTERNAL, 1 pins
Jun 27 08:43:16 mini kernel: usb-midi: fetchString(2)
Jun 27 08:43:16 mini kernel: usb-midi: fetchString = 4
Jun 27 08:43:16 mini kernel: usbmidi: found [ UM-1 ] (0x0582:0x0052), attached:
Jun 27 08:43:16 mini kernel: usbmidi: /dev/midi00: in (ep:81 cid: 0
bufsiz:64) out (ep:01 cid: 0 bufsiz:64)

However, the MIDI doesn't show up in alsa.
Here's /proc/asound/devices:[root mini etc]# cat /proc/asound/devices
  1:       : sequencer
 16: [0- 0]: digital audio playback
 24: [0- 0]: digital audio capture
  0: [0- 0]: ctl
 33:       : timer

Help! Where can I look for hints as to what's happening?

TIA


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]